5 Replies Latest reply on Feb 18, 2017 6:33 AM by KianHong

    Missing of avr/interrupt.h file when compiling softwareserial example on intel edison

    KianHong

      Hi guys, i've faced some problems with the missing of header file. Can anyone please help? I will mention in details what i wanted to do, perhaps anyone could guide me with a better way to achieve the goal.

       

      I'm using Intel Edison with Arduino Breakout board and using IDE sketches to write my code. I'm planning to use the built-in bluetooth feature to obtain data from android phone, but somehow I'm not sure how to do it. If anyone know, can just guide me in this way. Anyway, as i have no idea how to read data using the built in bluetooth, so i decided to use an external bluetooth module like how it is setup as a normal arduino uno, so i tried on the softwareserial example provided in the library. When i verify the coding, somehow it appears the error of #include<avr/interrupt.h> not found. But this only appear when my board is directed to tools/ board: intel edison. When i change it to arduino /genuino uno, the example just went well. Has anyone faced this using Intel Edison? Btw my IDE  version is 1.6.12 and i have tried on 1.8.1 as well, the problem still the same.