13 Replies Latest reply on Feb 28, 2017 2:16 PM by Intel Corporation

    NUC6i7KYK not powering up anymore

    MatthiasG

      Hi.

       

      I struggling w/ a power-up issue w/ my just recently bought (actually kinda brand new) Skull Canyon: while it worked PERFECTLY for ~a week it suddenly (during a video conf. call — thought I doubt it is related) powered off. Since then, I can not power it up again.

       

      My Status: the NUC is powering for roughly 2-3 seconds then shuts down (powers off).

       

      My Setup:

       

      - OS: Arch Linux

      - BIOS: KY0041

      - RAM: HyperX Impact HX424S14IBK2/32 32GB (2 x 16GB) RAM Kit (2400MHz DDR4 CL14 SODIMM, 1.2V, 260-pin

      - HDD:  Samsung SSD 960 Pro Series NVMe 512GB ML

       

      My analysis so far:

       

      1. w/ removed RAM (and HDD) the NUC is powering up until LED flashing 3 blinks (3 beeps) sequence — indicating a RAM issue (well, yes, because there is no ram, right?). Testing w/ one RAM module or even completely different RAM, see next bullet, doesn't help.

       

      2. Replacing RAM... following some pointers in the forum, speaking about RAM being the root cause of rather strange issues w/ the Skull, I've tried w/ a Crucial 32GB Kit (16GBx2) DDR4 2400 MT/s (PC4-192000) SODIMM 260-Pin Memory - CT2K16G4SFD824A — unfort. w/ out success.

       

      3. Trying a BIOS reset (via jumper) does not work because the NUC is either not powering "long enough" (w/ RAM installed) or not at all (flashing 3 blinks (3 beeps) sequence).

       

      Is there anything - apart from returning this otherwise wonderful piece of tech - that I could try? Some sort of reset, maybe...?

       

      Thanks a lot, any feedback highly appreciated.

      M.