1 2 Previous Next 18 Replies Latest reply on Apr 22, 2017 4:23 PM by MartyG

    error cod 0xA00F4243 (0xC00D3704)

    Jessemarti

      I have a HP Envy. I got my laptop a few months ago. Around September 2016. Every thing was working great but the past couple of weeks a error code 0xA00F4243 (0xC00D3704) appeared when I selected my camera app. Then I started getting a message with skype saying that my camera might being used by another app. But all app's were closed. Just to be sure I uninstalled Skype and one other photo app that uses the 3D feature just to be sure. And still same thing with camera App. So I looked for other posts with people who had the same problem. I found a solution. Uninstalled the "Intel RealSense Depth Camera F200" as advised to the poster.  And reinstalled "Intel RealSense Depth Camera manager from this Intel link: Download Intel® RealSense™ Depth Camera Manager

       

      Well After the reinstall I restarted my computer. Tried using my camera And got the same message and error code as before. I checked my Apps & Features under my settings. These systems have been udated:

      Intel Driver Update Utility

      Intel RealSense Application Recommender

      Intel RealSense Depth Camera manager F200 ( Checked to see what was running before I uninstalled. So this matched.)

       

      What else can I try?

        • 1. Re: error cod 0xA00F4243 (0xC00D3704)
          MartyG

          For machines with integrated RealSense cameras such as the Envy, I always recommend downloading the camera drivers from the driver section of the support website of your manufacturer (HP in this case).  This is because manufacturers may implement the camera into their equipment in ways that make it incompatible with the generic Intel-provided drivers used with the external cameras.

           

          HP Software and Driver Downloads for HP Printers, Laptops, Desktops and More | HP® Customer Support

           

          You should ensure that you uninstall any existing RealSense drivers and DCM that you currently have installed before installing the drivers downloaded from the HP support site.

          • 2. Re: error cod 0xA00F4243 (0xC00D3704)
            Jessemarti

            I tried downloading the HP Software. But during the Set up wizard. The set up failed and gave me a message that it did not detect a Intel® RealSense™ 3D camera. What do I do?

            • 3. Re: error cod 0xA00F4243 (0xC00D3704)
              MartyG

              As a next step, I recommend typing 'camera explorer' into the text box on the bottom of your Windows screen (next to the buton you use to shut Windows down), to find the Camera Explorer app.  When this is run, it should list the cameras that you have installed.  If your RealSense camera is shown, please click on it and see if you can use the apps to perform tests with the camera to see whether it is functioning or not.

              • 4. Re: error cod 0xA00F4243 (0xC00D3704)
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi Jessemarti,

                Do you have any updates about this case?

                Regards,
                Leonardo R.

                • 5. Re: error cod 0xA00F4243 (0xC00D3704)
                  Gromit

                  Same issue. I have a Lenovo Y700, with integrated F200 camera windows 10 up-to-date.

                  The F200 stopped working with that error code.

                  I unloaded the last DCM .exe installer, but it fails trying to update firmware (error -4).

                   

                  Please, give us a REAL solution.

                   

                  Thanks in advance.

                  • 6. Re: error cod 0xA00F4243 (0xC00D3704)
                    MartyG

                    Someone had the same issue with a Lenevo Y700 a year ago.  Looking at their description of the drivers listed in their Device Manager under the Imaging Devices section, they had an RGB and Depth driver listed, but not the third driver, the Virtual Driver.  Here's an image of my F200 in my Device Manager.

                     

                     

                    An absence of the Virtual Driver seems to cause some of the more advanced camera functions to be inoperable, whilst still allowing it to function like an ordinary RGB webcam.  Its absence can also be a cause of installation failures when installing the DCM.

                     

                    Could you check your Device Manager please on your Lenevo Y700 and see if the Virtual Driver is missing?

                     

                    If it is absent, retrieving a missing Virtual Driver is trickier with integrated cams than it is with the USB cameras.  My recommendation would be to right-click on the RGB and Depth drivers in your Device Manager and select the Uninstall option for each until you have no RealSense drivers listed in the Imaging Devices section.  Then try running the DCM installer again.

                    • 7. Re: error cod 0xA00F4243 (0xC00D3704)
                      Gromit

                      Thanks for your quick response. The virtual driver was present, and also Depth, under 'imaging devices'; the RGB, instead, was listed as 'unknown'. I removed Depth & Rgb, and launched DCM: same error (firmware could not be updated, rc=-4); I tried then uninstalling virtual driver too, same result. I reinstalled virtual driver (via 'add legacy software'), still nothing.

                      • 8. Re: error cod 0xA00F4243 (0xC00D3704)
                        MartyG

                        The next logical step would be to go to the Lenevo driver support webpage for your model and download the camera drivers for your internal F200 camera from it.  Sometimes manufacturers make tweaks to the setup of their built-in cameras that make them incompatible with the regular drivers used by external RealSense USB cameras.  so it's often a very good idea to try the manufacturer's drivers first before using the ones supplied by Intel's RealSense downloads page.

                        • 9. Re: error cod 0xA00F4243 (0xC00D3704)
                          Gromit

                             Sorry, but I don't agree with that.

                           

                             My laptop is a brand new Lenovo. I bought it two months ago. The camera worked fine. Then, for some reason I don't understand (some Windows update, maybe), out of the blue, it began to give this error.

                           

                             The Lenovo program I found to do this work, seems to be calling Intel DCM, and obviously abends, without giving further information.

                           

                             I've been struggling with this issue several days, and trying so many things that I can't recall now.

                           

                             Is there not a way to solve this starting from zero? Is there not a way to tell DCM installer to NOT update firmware? Is there not anyone having this same issue, that could give me a hand?

                           

                             Thanks and regards

                             Lucas

                          • 10. Re: error cod 0xA00F4243 (0xC00D3704)
                            MartyG

                            There were reports of cameras stopping working after April 4 when Microsoft released their latest Preview build.  I understand your frustration but it is important to consider all reasonable possibilities for the cause of a problem, even though there may seem to be an obvious cause such as the camera stopping working right after a Build update.

                             

                            My experience is that if it related to a Preview Build then there is little chance of fixing it until Microsoft do something to a future Build that fixes a camera issue, either deliberately or accidentally.  I really do know how annoying it is to be in that situation.  The last discussion thread involving a Build disrupting the camera ended up being  4 pages long because of the number of people it affected and the number of different fixes they were trying.

                             

                            SR300 not working in Windows 10 Insider 14986

                             

                            As I said earlier, it's much easier to update the drivers without the DCM if you have an external USB cam rather than an internal cam.   This is because after you do an Uninstall on the drivers in the Device Manager, you can pull the camera out of the USB port, plug it back in and Windows 10 automatically downloads the drivers back into the Device Manager via the internet.

                             

                            The update process apparently works through Windows Update.  So although I haven't tried this method myself and it's just speculation, I would try uninstalling the drivers and then opening Windows' "Check for Updates" window and clicking the 'Check for Updates' button on that window to see if if reinstalls the RealSense drivers into the Device Manager without needing to update the firmware.

                            • 11. Re: error cod 0xA00F4243 (0xC00D3704)
                              Gromit

                              Windows update also fails, this time with rc 0x80070643:

                              "There were problems installing some updates, but we'll try again later. If you keep seeing this and want to search the web or contact support for information, this may help:

                              • Intel(R) Corporation - Other hardware - Intel(R) RealSense(TM) 3D Camera (Front F200) Depth - Error 0x80070643"

                               

                              I'm trying now starting manually FWUpdate200.exe, and see this:

                              >FWUpdateF200.exe -isConnected
                              CIVCAM_DLL::InitCamera() failed, error code: 1280
                              CIVCAM_DLL::InitCamera() Attempt to stop DCM Service and init camera again
                              enter inStopDCMService()
                              inStopDCMService() failed
                              CIVCAM_DLL::InitCamera() failed, error code: 1280
                              In recovery mode

                              **********************************************************
                              Intel(R) RealSense(TM) Firmware Update Tool Version 1.4.27.52404
                              Copyright (C) Intel(R) Corporation.  All Rights Reserved.

                              Camera Connection Check:
                              **********************************************************

                              Error Recovery Required. Update should be performed
                              IV Camera status: Camera is in recovery mode

                               

                              >FWUpdateF200.exe -checkSetup
                              **********************************************************
                              Intel(R) RealSense(TM) Firmware Update Tool Version 1.4.27.52404
                              Copyright (C) Intel(R) Corporation.  All Rights Reserved.

                              Check Setup. Check MFT0 files exist and are registered:
                              **********************************************************

                              Missing Mft0 file.
                              Make Sure the Following files exist
                              C:/Program Files (x86)/Common Files/Intel/RSDCM/bin/win32/IntelRealSense3DcameraPlugin.dll,
                              C:/Program Files/Common Files/Intel/RSDCM/bin/x64/IntelRealSense3DcameraPlugin.dll

                               

                               

                              Can this help? This 'dll' is not present. More than that, the entire /RDDCM directory is missing.

                              l.-)

                              • 12. Re: error cod 0xA00F4243 (0xC00D3704)
                                MartyG

                                From the log, it looks again as though the camera is not being detected.  My interpretation of the log is that it's not the Update process in general that is failing, but its attempt to install the camera's Depth driver specifically.

                                 

                                I believe the RSDCM folder is installed as part of the DCM (the name is short-hand for RealSense DCM).  So if you are not able to complete installation of the DCM, that would explain the absence of that folder.

                                • 13. Re: error cod 0xA00F4243 (0xC00D3704)
                                  Gromit

                                  Still stuck with this, no advances. I'm attaching status of the devices, may be seeing this you can figure out what way I should try.1.jpg2.jpg3.jpg4.jpg5.jpg6.jpg7.jpg

                                  • 14. Re: error cod 0xA00F4243 (0xC00D3704)
                                    MartyG

                                    The yellow exclamation marks beside the RGB and Depth drivers in the Device Manager are a clear sign that things are not as they should be there.  It indicates that those drivers are malfunctioning in some way. 

                                     

                                    Today I found out about a Troubleshooting interface in Windows.  You might want to give that a try.

                                     

                                    Re: Intel RealSense SR300 Camera failed to install

                                    1 2 Previous Next