7 Replies Latest reply on Mar 23, 2017 3:09 AM by fager

    Getting 45 Mb/s wifi download speed on 100 Mb/s network

    Dominik523

      Hello everyone! I'm using Lenovo Z50-70 notebook with Intel AC 3160 network card inside. I have a modem with 100 Mb/s download and I'm recieving download speed of 45 Mb/s on the notebook while my friend gets around 70 Mb/s on his ThinkPad. Has anyone else had this problem before? I tried to change bunch of settings in driver's settings according to some other forum posts from different sites but nothing helped.

      I'm using Windows 10 64 bit. Driver version is 18.33.5.1

      I really appreciate any help.

       

      Best regards,

      Dominik

        • 1. Re: Getting 45 Mb/s wifi download speed on 100 Mb/s network
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Dominik523,

          We understand you're facing slow download speeds on your Lenovo* laptop using our Intel® Dual Band Wireless-AC 3160 adapter.

          In order to get a better picture of the issue, please download and run our System Support Utility. This application will scan your system and allow you to save the results to a file, please make sure to run this report while connected to your wireless network. You may then attach this report to your reply by switching to the "advanced editor," after which the attach option (paper clip) should appear at the bottom of the reply box.

          Aside from this, please let us know the brand and model of your wireless router/access point.

          We look forward to hearing back from you.

          Best regards,
          Carlos A.

          • 2. Re: Getting 45 Mb/s wifi download speed on 100 Mb/s network
            Dominik523

            Hello Carlos!

            I'm sorry for not respoding for a long time, I was unable to get to my PC.

            I attached the system information file into this message.

            Also my router model is ZTE ZXDSL 931VII

            • 3. Re: Getting 45 Mb/s wifi download speed on 100 Mb/s network
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello Dominik523,

               

              It's likely that the slower download speeds are being caused by your adapter connecting at a slower rate to comply with your 802.11n router, plus it being a 1x1 model (one antenna supporting one data stream) as opposed to 2x2.

               

              For optimal performance, we can recommend upgrating to a wireless AC capable router. However we do have some simple suggestions that could help while keeping your current hardware configuration.

               

              We normally don't recommend using the 40 MHz channel width in the 2.4 GHz band, Channel Bonding could help increase your download speeds. The only problem is that it will also make you more vulnerable to interference.

               

              From your router's menu, you'll simply need to change the "Channel Width" setting up to 40 MHz to enable channel bonding, or back to 20 MHz to disable it again, if it turns out to hurt more then it helps.

               

              - How to log into your router and change settings.

               

              NOTE: Any links provided for third party tools or sites are offered for your convenience and should not be viewed as an endorsement by Intel® of the content, products, or services offered there. We do not offer support for any third party tool mentioned here.

               

              After this we can also switch your wireless adapter to a mode that will be more compatible with your router. For this we'll need to open the Device Manager from the Control Panel. Then we'll expand the Network Adapters category, and double click on your Intel(R) Dual Band Wireless-AC 3160 to enter the Properties menu.

               

              Under the "Advanced" tab you will need to scroll down and set the "HT Mode" to "HT Mode." By default this is set to VHT (Very High Throughput), which enables Wireless AC. Lowering this setting to HT (High Throughput) may help decrease data loss when connecting to a Wireless N network.

               

              Please let us know if this helps, or if you have any questions.

               

              Best regards,
              Carlos A.

              • 4. Re: Getting 45 Mb/s wifi download speed on 100 Mb/s network
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hello Dominik523,

                We're following up on your thread since we have not heard back from you.

                Has your issue been resolved? Please let us know if you need any further assistance.

                Best regards,
                Carlos A.

                • 5. Re: Getting 45 Mb/s wifi download speed on 100 Mb/s network
                  Dominik523

                  So the thing is, most likely my ISP has disabled changing Channel Width option in my router settings. I think that because I can't find that option anywhere.

                  Thanks for your help. Looks like I will have use my router as it is and that's it.

                   

                  Best regards,

                  Dominik

                  • 6. Re: Getting 45 Mb/s wifi download speed on 100 Mb/s network
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Dominik523,

                    You're welcome. Thank you for you patience.

                    If you need any further assistance, please let us know. We're always happy to help.

                    Best regards,
                    Carlos A.

                    • 7. Re: Getting 45 Mb/s wifi download speed on 100 Mb/s network
                      fager

                      What i found in Lenovo Z50-70 Laptop Manual is go to network connections and click on the wifi adapter. What is the link status and signal bar strength? Right click the adapter and go to properties. From there click on configure button and advanced button. In there switch it to performance and auto speed negotiation to auto if it's set manually or set it to just G only. Some wifi cards have very basic settings in there and some have a lot more. Some of those settings can mess with the link speed. Instead of 10/10 full duplex set to 100/100 full duplex etc. Maybe turn on/off packet offload etc