11 Replies Latest reply on Mar 2, 2011 7:19 AM by

    DX58SO Can not enter the BIOS

    Nemo

      Hi,

      I have a DX58SO Main board with 3GB RAM *(TRI) and 1 SATA Hard Drive, the OS is WIN XP PRO.

      when I start the computer I get the message

      Disk Information:

      No Hard Disk is detected...

      But it loads windows and every thing works fine.. one problem I experienced, is that I can not enter the bios. i hit F2 but nothing happens,, it keeps loading windows and i can not enter the BIOS.. Please someone help me. I need to make some configuration in BIOS.

      Cheers/ Nemo

        • 1. Re: DX58SO Can not enter the BIOS
          Boyet

          Perform bios recovery. Use the latest bios version.

          • 2. Re: DX58SO Can not enter the BIOS
            Aryan2411

            Hi there,

             

            It is best to try the steps below.

             

            Try to do a CMOS clear of the board.
            Put the bios jumper to the maintenance mode.

            It should go on the bios page without pressing F2.

             

            Put back the jumper to default position when done.

            If it is not booting, remove the memory to check if the board issues any beeps
            Result:

             

            Then last thing to do is to recover the bios using the Recovery Method as stated by our friend.

            Kind Regards,
            Aryan.

            • 3. Re: DX58SO Can not enter the BIOS
              Boyet

              You may try going to the bios and put everything back to default settting. After that set what is necessary depending on what you have with your system. Or you may do what I have suggested earlier.

              • 4. Re: DX58SO Can not enter the BIOS
                Nemo

                I wish I could do that.. My problem in first place is that I can not enter the bios.. I never changed any thing there..

                • 5. Re: DX58SO Can not enter the BIOS
                  Boyet

                  One way is the bios recovery method using the latest bios version and the other way to go into bios and implement what I have suggested is the maintenance method.

                  • 6. Re: DX58SO Can not enter the BIOS
                    Nemo

                    what do you mean by recovery? to just update to latest bios? well I need to enter the bios to get the ethernet to work first.. so I can not connect to internet to update the bios. and I tried with USB memory, and it doesnt work either. so again, i have to enter the BIOS but it doesnt work.

                    • 8. Re: DX58SO Can not enter the BIOS

                      Hello there!

                      I have the exactly same problem. I've just bought this motherboard (I'm in Kazakhstan, so don't be surprised ). I've downloaded the latest 5529 BIOS, and flashed it through Windows first. There were no problems during BIOS update. But when I turn on my computer, there are no sign: "Press F2 to enter setup". There is only "Press F10 to Boot...". I keep pressing the F2 button, but it doesn't work.

                      I switched the BIOS jumper to "Configure" position, and a black BIOS screen appears. But my keyboard doesn't work, thus I cannot navigate the menu.

                      Then I've tried to recover BIOS from USB flash drive as described above. I've removed the BIOS jumper, and everything went OK. But I still cannot enter the BIOS. There is still no "Press F2..." option.

                       

                      BTW, my CPU is i7-930, my keyboard is Logitech Illuminated (USB corded).

                       

                      What else can I do in order to enter the BIOS (besides of buying new motherboard)?

                      • 9. Re: DX58SO Can not enter the BIOS
                        Doc_SilverCreek

                        Can you try a different keyboard?

                         

                         

                        Seems a lot of folks on a lot of different vendors systems can't get into BIOS with this keyboard.

                        http://forums.logitech.com/t5/Keyboards-and-Keyboard-Mice/Logitech-Illuminated-Keyboard-unusable-to-enter-BIOS-prior-to/td-p/289945

                        • 10. Re: DX58SO Can not enter the BIOS
                          parsec

                          Yes, those posts in the Logitech forum sum it up quite well, there is a definite problem with this keyboard.

                           

                          There seems to be a work-around according to one poster (?) on the third page of the thread.  According to that, if you happen to have an external USB hub that is powered from it's own power source (wall wart), plug the keyboard into the hub, which should be powered up, and of course is connected to the PC.  Do this with the PC off!  Apparently, you'll need to let the keyboard run or "wakeup" for a while before turning on your PC, for about 30 seconds.  Then start your PC and try to enter the BIOS.

                           

                          I can't test this since I don't own this keyboard, but if you have a powered USB hub it is worth a try, and if it works let us know.

                          • 11. Re: DX58SO Can not enter the BIOS

                            Hello there!

                            Sorry for a late response, and thank you all for your advices! I’ve tried to plug my Logitech Illuminated keyboard via USB hub, but it was fruitless. I ended up with one of the cheapest keyboard – Genius LuxeMate i200. It works and lets me to enter and change BIOS settings. So now I’m proud owner of two keyboards – one for work, and one for BIOS.

                            It should be noted though, that Logitech Illuminated works well with my two other motherboards – Asus P5LD2SE and Intel DG945GCLF2.