1 2 Previous Next 16 Replies Latest reply on Feb 23, 2010 9:39 AM by Boyet

    DX58SO No disk is detected

    kilgore661

      Hello Everyone,

       

      I have just started putting together a DX58SO-based system. I have one hard disk and the DVD connected. When I boot I see the Intel splash screen, then a black screen with something like "Marvell SE81xx Adapter ..." shortly followed by the message "No disk is detected".

       

      I can see the disk in the BIOS boot menu, so I am not sure what the problem is. Any thoughts?

       

      I have tried booting from a Vista64 DVD. This works until I am asked to choose a disk to install Vista onto, but there are no disks to choose from.

       

      I haven't built a system for a while, so consider me a noob.

       

      661

        • 1. Re: DX58SO No disk is detected
          Boyet

          Disable the boot ethernet network option in the bios. You can also change the boot order so that the first boot is the dvdrom then your hdd.

          • 2. Re: DX58SO No disk is detected
            kilgore661

            Thanks for the suggestions. Boot order was already DVD first, then HD. I disabled Boot to Network and tried again - same result: computer says "Adapter 1: No disk detected", boots from Windows DVD but then fails at the format partition (XP disk) or select a partition to instal to (Vista64)

            • 3. Re: DX58SO No disk is detected
              Boyet

              I'm assuming that you have a sata hdd. Chose AHCI in the bios. You may have to prepare your hdd if the program cannot find any partition. Try downloading the hdd program in the hdd manufacturers website. Run it before installing the vista 64 os.

              • 4. Re: DX58SO No disk is detected
                kilgore661

                Your assumption is correct (this m/b has only SATA sockets). Thanks for the last idea but it didn't change anything: still says "no disk detected" and Vista disk says no disks to install to.

                 

                Edit: will look for Samsung disk preparation program.

                • 5. Re: DX58SO No disk is detected
                  Boyet

                  Under Configuration/sata drives you should see the hdds connected to port numbers. Check this out to be sure that your hdd is recognized by the bios. Under boot menu disable all devices not needed temporarily to simplify the present situation.

                  • 6. Re: DX58SO No disk is detected
                    kilgore661

                    Ok, on my system I have Advanced->Drive Config ad the settings there are

                     

                    ATA/IDE Mode: Native (this can't be changed)

                    Config SATA as: AHCI

                    SMART: Enable

                    SATA Port 0: SAMSUNG HD501LJ

                    SATA Port 1: (my DVD drive)

                     

                    all other SATA ports: Not installed

                     

                    Hard Disk pre-Delay: 0

                     

                     

                    Under Boot I have

                    Boot Menu Type: Normal

                    HD Order: P0 Samsung HD501

                    CD/DVD-ROM Boot Order: (my DVD)

                     

                    All other boot types are disabled.

                     

                    The only other entry that I'm not sure is irrelevant (such as ZIP Emulation Type: Floppy) is

                     

                    UEFI boot: disabled.

                     

                     

                    but the problem persists.

                     

                    Thanks for this help by the way.

                     

                    661

                    • 7. Re: DX58SO No disk is detected
                      Boyet

                      The bios setting is now correct. I'd like to suggest that hdd be connected to sata port 1 and dvd to sata port 0. BTW, your hdd is recognized by the bios and that's good news. Try again to install the os. if still you have the problem, you can connect the hdd in another computer with windows running using an external enclosure. Use Disk management to partition and format your hdd in NTFS format. Once this is done place it back to your DX58SO system and try installing the os.

                      • 8. Re: DX58SO No disk is detected
                        kilgore661

                        Hmm. I've already had the DVD and HD in the configuration you suggest and the disk is already formatted as NTFS - or it was when I took it out of my other computer. I suppose it's possible it has become unformatted in some way what with the XP32 installer having a go at formatting it. I'm not sure what you mean by an "external enclosure".

                         

                        I will put the disk back in my working machine and check that it is formatted. But that won't be until tomorrow now.

                         

                        Thanks again for your help so far!

                         

                        661

                        • 9. Re: DX58SO No disk is detected
                          Boyet

                          The hdd must be partitioned and formatted without any OS installed. When the vista installer is running does it asked you where it should be installed? And a partition is displayed? If a partition is displayed select it and delete it and let vista repartiton it before proceeding with the installation of the os.

                           

                          An external enclosure is a box where you place your hdd. You connect the enclosure using usb or esata cable depending on the type of enclosure that you have to your computer externally. In short it is just an external drive.

                          • 10. Re: DX58SO No disk is detected
                            kilgore661

                            I've swapped the drives around so that the DVD is on Port 0 and the HD on Port 1, and I have formatted the drive as NTFS using Vista on my other computer. The disk is still "not detected" at boot.

                             

                            In answer to your question, the Vista installer asks me where I want to install Windows. It shows me a window that should contain a list of available drives but it is empty. There is a warning symbol at the bottom of the window saying "No drives were found. Click Load Driver to provide a mass storage driver for installation".

                            • 11. Re: DX58SO No disk is detected

                              I'm having similar issues on a DX58SO system using Windows 7-64bit with

                              all the latest driver updates; with a Seagate 500MB primary drive and a

                              second Seagate 1 TB data drive.

                              The BIOS registers both HDDs accurately. However, everytime I start up and login,

                              I have to go to "Device Manager" and scan for new hardware

                              to the Disk drives the second HDD. It adds the new device and everything

                              works fine but I have to perform the "scan" everytime!

                              It almost seems to treat it like an external device.

                              I've performed the same thing with another Maxtor SATA HDD with same results.

                              This is all new hardware so I'm not sure what could be causing this.

                              Any ideas are appreciated.

                              • 12. Re: DX58SO No disk is detected
                                Boyet

                                This drive has some issues as discussed by owners in other forum websites. Some of the solutions which you might try are the following:

                                1. Try using a different sata port. It could be port 2, 3, and so on. This is to insure that it's not the mobo's port.

                                2. Try using flash drive installation or if your OS is burned to cd/dvd from an iso image burn it at a lower speed.

                                3. Try setting bios to IDE mode instead of AHCI or raid.

                                4. You might also try loading a scsi/AHCI driver when installing the OS. This is explained by samsung in their website as the reason why the drive could not be found.

                                5. Update your bios.

                                 

                                There others out there, so its better to find them and explore.

                                • 13. Re: DX58SO No disk is detected
                                  kilgore661

                                  Thanks Boyet. I have marked your last post as the correct answer because it contains a suggestion that solved my problem. The answer appears to be "Don't use the Samsung disk". I swapped it for a Velociraptor and the Vista installer worked first time. FWIW the Marvell controller still says "No disk is detected" but Vista is installed. Also, I contacted Samsung tech support and they were useless - they didn't even read what I said and sent me the bog-standard "check your cables" reply.

                                  • 14. Re: DX58SO No disk is detected
                                    Boyet

                                    Glad to hear that you have solve the problem. The Marvell controller is another issue with your motherboard and is being discussed in another thread.

                                    1 2 Previous Next