1 Reply Latest reply on Feb 6, 2017 4:46 PM by Intel Corporation

    Setting system time on Intel Edison

    NewMech

      Hi,

      I'm following this post: Setting time zone and synchronizing time with time server on Edison

      And I'm doing something following his guide, instead he set his timezone to Chicago, I set my time zone to GMT+7:

       

      root@newmech:~# rm /etc/localtime

      root@newmech:~# ln -s /usr/share/zoneinfo/Etc/GMT+7 /etc/localtime

      root@newmech:~# ls -l /etc/localtime

      lrwxrwxrwx 1 root root 29 Feb  5 06:45 /etc/localtime -> /usr/share/zoneinfo/Etc/GMT+7

       

      Then I reboot and recheck the system time, it's

       

      root@newmech:~# date

      Sun Feb  5 06:46:50 GMT+7 2017

       

      The GMT+7 is true, but the time is not true, I'm in Vietnam (GMT+7), and the true time is 20:46 (My computer time)

       

      I've try to sync with www.nist.gov or time.windows.com but the edison cannot connect to these servers.

       

      Am I doing something wrong?

        • 1. Re: Setting system time on Intel Edison
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi NewMech,

           

          Thanks for your interest in the Intel® Edison Platform.

           

          We appreciate all the information provided. In order to get the correct zone time, please follow the steps you have posted but change this command:

           

          - root@newmech:~# ln -s /usr/share/zoneinfo/Etc/GMT-7 /etc/localtime


          After it you will get the correct time, please try this and let us know your results.

           

          Have a nice day!

           

          Regards,
          -Yermi A.