1 2 Previous Next 19 Replies Latest reply on Jul 5, 2017 9:42 AM by Intel Corporation

    How to "Linux" the NUC

    John_BR

      I hope this will start a discussion on the use of NUC6i5/NUC6i3 with Linux distributions (i.e. Debian, Ubuntu, Mint, and others)

       

      Screenshot from 2017-02-13 01:30:37.jpg

      For some time I was reluctant to buy a NUC since all feedback I found was about bugs and unsupported devices.  For many years I used Intel semiconductors in my projects and PC platforms.  So I really was sad about the lack of interest of Intel staff to support the Linux community, after all we also buy lots of motherboards and CPUs and devices from Intel.

       

      Then I found a project called Opensource 01.org | Intel Open Source Technology Center  that turn on a light for the my quest, so I decided this new year to invest in a new NUC kit the NUC6i5SYH which I installed 2x4GBytes of RAM, a 250GByte SSD/M2 and a 500GB HDD/SATA to test and be able to retire my Gigabyte desktop tower, if all goes well.  The power efficiency was the first point that caught my attention, which is my area of interest since college.  I have tested many low power units, of many brands, for business development, and this NUC really did look promising.

       

      So this is my test log with the mighty, greener, smaller footprint desktop killer that Intel is developing and the work around solution I have to share with our great GPL/GNU community of enthusiasts and professional IT experts that do not take for granted closed black box systems.  Go were no one has gone before.

       

      The first week with my NUC6i5 was very strait forward.  I downloaded the best version (by my research)  http://releases.ubuntu.com/14.04/ubuntu-14.04.5-desktop-amd64.iso.torrent that could bundle support for most of the hardware devices included and used the mkusb to create a USB live ubuntu installation device.  You can use a USB stick or a SD card.  I used a microSD with a USB adapter.  Since the ISO image is less than 2Gbytes usually today any SD or USB drive is fine.

       

      I decided to make the first install on the HDD, since I am not comfortable, yet, with SSD's limitations, (ie.  SSD vs. HDD ), since I could need to reinstall the system many time on this first test, and last, but not least, 10 second or 1 second boot time is not a problem for my applications and use of the NUC.

       

      My partition strategy is using the advantages of EFI:

       

      NAME   MAJ:MIN RM     SIZE  RO TYPE        MOUNTPOINT

      sda      8:0    0   465,8G  0  disk

      ├─sda1   8:1    0     243M  0  part FAT32  /boot/efi*   bootloader/grub

      ├─sda2   8:2    0    47,7G  0  part Ext4   /

      ├─sda3   8:3    0   114,5G  0  part Ext4   /home

      └─sda4   8:4    0     3,8G  0  part        [SWAP]

              Notice there is free space left for other uses, and /dev/sdb not in use.

       

      OK, so after the install and boot, most devices worked: boot screen, system screen (then logging screen), network (ie. wifi) just connected and ask for the password, Bluetooth was on (had to disable it manually), and I noticed a heat issue, compared to the Live USB test with just the SSD installed, prior to installing the HDD.  I rebooted and tweaked the cooling configuration of the UEFI GUI and ajusted the threshold temperatures and the fan started to be more present (ie. I could now hear it working more often) and the temperature was under control again (notice: I keep air conditioning off at my SOHO for lower carbon footprint).  I then installed lm-sensors, gkrellm, acpi packages and did some google search to fine tune the configuration files.  The probing of the sensors (ie. using sensors-detect command) shows Found unknown chip with ID 0x8607

       

      I would suggest this git project Support for IT8607E  for the tip on using the:

       

      sudo modprobe --verbose it87 force_id=0x8603

       

      this did really work around the lack of a module for the used chip in the NUC (hope Intel helps us here to fine tune measurements ).

       

      This is the output I get with sensors command:

       

      NUC-John:~$ sensors

      acpitz-virtual-0

      Adapter: Virtual device

      temp1:        +27.8°C  (crit = +105.0°C)

      temp2:        +29.8°C  (crit = +105.0°C)

       

      coretemp-isa-0000

      Adapter: ISA adapter

      Physical id 0:  +45.0°C  (high = +100.0°C, crit = +100.0°C)

      Core 0:         +44.0°C  (high = +100.0°C, crit = +100.0°C)

      Core 1:         +43.0°C  (high = +100.0°C, crit = +100.0°C)

       

      it8603-isa-0a40

      Adapter: ISA adapter

      Vcore:                     +0.62 V  (min =  +0.55 V, max =  +1.52 V)

      SDRAM:                     +1.21 V  (min =  +1.14 V, max =  +1.26 V)

      3VSB:                      +3.29 V  (min =  +3.14 V, max =  +3.46 V)

      Vbat:                      +2.93 V 

      +3.3V:                     +3.31 V 

      System Fan:               5000 RPM  (min = 1997 RPM)

      Memory Temp:               +45.0°C  (low  =  +0.0°C, high = +95.0°C)  sensor = thermal diode

      Motherboard Ambient Temp:  +43.0°C  (low  = +15.0°C, high = +90.0°C)  sensor = thermal diode

      PCH Temp:                  +47.0°C  (low  = +35.0°C, high = +100.0°C)  sensor = disabled

       

      As you can see, still needs some fixes of the sensors configuration file, but we are on the right track.

       

      That is all for now.  Hope to get some feedback.  Long Live Linux!

        • 1. Re: How to "Linux" the NUC
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello John_BR,

           

          Thank you very much for sharing your results with the community, I am pretty this will help other users and I would like to encourage the community join and add more feedback.

           

          As you mentioned, Linux has not officially been tested on Intel® NUC; however, that there are lot users out there using it hopefully some of them can join the thread.

           

          Regards,

          Amy.

          • 2. Re: How to "Linux" the NUC
            rizzla08

            Hi John_BR,

             

            I am also interested in Linux on NUC! I just posted a separate question on the forum about my hope of getting a NUC6i7KYK to run Ubuntu and being able to control it headlessly and wirelessly from a separate laptop. I don't have my unit in hand yet, but I just ordered a NUC6i7KYK with 1TB M.2 SSD and 32GB DDR4 RAM. Hoping to make it a portable bioinformatics station. All of the bioinformatics tools I want to run are Linux-based, so I'll be traveling down the Ubuntu/NUC path shortly. Happy to keep in touch about tips and tricks. I'll check back on this thread often, probably with more questions than answers. But, anyway, figured I'd stick another flag in the sand with you :-)

            • 3. Re: How to "Linux" the NUC
              patcher

              Hello all,

              Dutch'ie,  here so don't be to harsh on my grammar or other English.

               

              BIOS
              Date01/18/2017
              VendorIntel Corporation (www.intel.com)
              VersionRYBDWi35.86A.0362.2017.0118.0940
              Board
              NameNUC5i7RYB
              VendorIntel Corporation (www.intel.com)

               

              -Version-

              Kernel : Linux 4.9.6-1-ARCH (x86_64)

              Compiled : #1 SMP PREEMPT Thu Jan 26 09:22:26 CET 2017

              C Library : GNU C Library version 2.24 (stable)

              Default C Compiler : GNU C Compiler version 6.3.1 20170109 (GCC)

              Distribution : Arch Linux

              Desktop Environment : Unknown (Window Manager: GNOME Shell)

               

              I have more difficulties tweaking the bios, then running Linux

              Long term Intel ONLY user, and bought this 1 because my DX58SO died.

               

              I'am really impressed by this 2 "pack of cigarettes" Intel box and had no doubts what so ever, that  it couldn't run or had problems

              with Linux.

               

              So u can ad Arch distro to the list, its running p e r f e c t l y.

               

              Ciao form the Netherlands.

              Bart.

              • 4. Re: How to "Linux" the NUC
                John_BR

                Dear Linux colleague,

                 

                Hartelijk dank voor uw deelname. Sorry voor het niet spreken uw taal geweldig (ik beschouw geluid en mooi), maar een echte uitdaging om te leren.

                 

                Hope to hear from you, and please share with us all your "howto" get your NUC to Linux.

                 

                Cheers!

                 

                • 5. Re: How to "Linux" the NUC
                  John_BR

                  Just adding more information here, about my new findings:

                   

                  I am on a daily base, spending more time on the NUC and I just encountered the "power-on" problem after shutdown.


                  What I have done other then what others have done (i.e. disable s4/s5 on EFI/bios setup GUI) is this: I disabled the "wake on CIR" too.

                   

                  After that, it is still working right (for the last few shutdowns) and I am suspicious that it has to do with how the CIR sensor, on board, near the edge (made of aluminum/metal ) is dealing with the heat emission.  My theory is that the CIR is mistaking the heat emission as if it were a IR signal, which turns on the device.  I will test more and reply here.

                   

                  SYS

                   

                  UPDATE:  After a few days I believe now that the fix disabling WoCIR  did not work.  I will test other options and update soon.

                  • 6. Re: How to "Linux" the NUC
                    John_BR

                    Tip: to see the firmware version that you are running, using the terminal instead of having reboot and enter the startup boot menu GUI, use this command at a terminal:

                     

                    sudo dmidecode -s bios-version

                     

                    The output will be like this:

                     

                    # SMBIOS implementations newer than version 2.8 are not

                    # fully supported by this version of dmidecode.

                    SYSKLi35.86A.0054.2016.0930.1102

                     

                    cheers!

                    • 7. Re: How to "Linux" the NUC
                      John_BR

                      OK, so this is the question I need a answer from Intel experts.

                       

                      I am using firmware SYSKLi35.86A.0054.2016.0930.1102

                       

                      I would like to upgrade to address the poweroff problem (I hope the new firmware will fix this).

                       

                      I have done some research about this and that if I upgrade my NUC with Ubuntu installed, I will not be able to boot back in my system and will need to do a fresh install.  Is this true?

                       

                      I have updated the bios before installing the system and not after that.

                       

                      Please share your experience with this tricky situation.

                      • 8. Re: How to "Linux" the NUC
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        Hi John_BR,

                         

                        Since this operating system has not officially been tested on Intel® NUC, I would not be able to confirm that question. However, I can go head and review it, and also the poweroff issue mentioned.

                         

                        Regards,

                        Amy.

                        • 9. Re: How to "Linux" the NUC
                          Intel Corporation
                          This message was posted on behalf of Intel Corporation

                          John_BR, we tried this with one of our Intel® NUC Kit, Ubuntu installed and it worked without any issues. It must say that it is always recommended to backup the information before any update, but I can share with you that our unit is currently working fine.

                           

                          Regards,

                          Amy. 

                          • 10. Re: How to "Linux" the NUC
                            Intel Corporation
                            This message was posted on behalf of Intel Corporation

                            John_BR, were you able to update the BIOS?

                             

                            Regards,

                            Amy.

                            • 11. Re: How to "Linux" the NUC
                              John_BR

                              Dear Amy,

                               

                              Thank you for the reply and your effort to test it.  As I wrote, before I installed the OS the BIOS update did work fine.  I will try to update, based on your positive feedback and post here a update as soon as I return to my office, in a few days, since I am away on a business trip.

                               

                              Regards,

                               

                              John

                              • 12. Re: How to "Linux" the NUC
                                Intel Corporation
                                This message was posted on behalf of Intel Corporation

                                Sure, I will be waiting for your results.

                                 

                                Regards,

                                Amy.

                                • 13. Re: How to "Linux" the NUC
                                  John_BR

                                  Dear Amy,

                                   

                                  I just did the update (using the SY0057.bio file and F7 at power startup).

                                   

                                  nuc_bios_update.jpg

                                   

                                  What I noticed different, from first update I did, was a louder "click" sound (like a mechanical relay click) after navigating to the option/line and confirmed it with a <Enter>.

                                   

                                  Then I got a black screen, a few seconds of suspense (I confess I did say a pray during the waiting time...), and then the screen shown above started to reveal it self, with different delays between each line.

                                   

                                  Then system rebooted.  I got a cordovan color screen (similar to ubuntu boot screen, but without text); then the ubuntu loading text and login next.

                                   

                                  The power-off problem (turns back on after shutdown) still is present.  I need to soft-power-off two time to make it turn off, so I am suspecting a "charge capacitor", somewhere, could be the cause of this glitch, because I noticed that it does power-off if I shutdown quickly after power-on.  That is, it needs time "on" to be able to repeat the shutdown problem.  Need more work on this.

                                   

                                  LLAP  \V/,

                                  • 14. Re: How to "Linux" the NUC
                                    Intel Corporation
                                    This message was posted on behalf of Intel Corporation

                                    Please let me know if you continue on testing this matter.

                                     

                                    As a recommendation you can always use the Ubuntu Forums in order to get peer to peer assistance, there might be someone there than can add more feedback in regard to this issue. Ubuntu Forums; Ubuntu Forums.

                                     

                                    Regards,

                                    Amy. 

                                    1 2 Previous Next