3 Replies Latest reply on Jan 25, 2017 11:08 AM by Intel Corporation

    Intel NUC + Razer Core Error 43

    lemon93

      Hi,

       

      I've recently just purchased a Razer Core and a Gigabyte G1 GTX 1080.

       

      When I placed the GPU into the Razer Core and connected to the Skull Canyon, installed Razer Synapse, installed the GPU drivers, I saw an error 43 in the GTX1080 under device manager.

       

      Despite several reinstalls and firmware updates to Intel HD Graphics, Thunderbolt, GPU drivers and Windows Updates, im still facing the same error.

       

      My Thunderbolt firmware is 18.05.

       

      The USB section of the Razer Core is usable though.

       

      Any solutions to the error 43?

       

      Appreciate for the help!

        • 1. Re: Intel NUC + Razer Core Error 43
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello :
           
          Error 43 is usually a hardware initialization issue, one of the things we can try now is to check the PCIe ports in order to make sure the Razer Core is properly connected to it, also BIOS update on the NUC will be a good thing to try.
           
          Besides that error on device manager, are you having any type of problem with the NUC’s performance, it is working properly?
           
          Instructions to do the BIOS update using the F7 method on the NUC:
           
          http://www.intel.com/content/www/us/en/support/boards-and-kits/desktop-boards/000005724.html
           
          And this is the .BIO file needed to do the update to version 0042, latest:
           
          https://downloadcenter.intel.com/download/26338/BIOS-Update-KYSKLi70-86A-?product=89187
           
          Not sure if the following drivers were the ones you tried already, just to make sure, this is the thunderbolt driver:
           
          https://downloadcenter.intel.com/download/26052/Thunderbolt-Driver-for-Intel-NUC-Kit-NUC6i7KYK?product=89187
           
          This is the thunderbolt firmware update:
           
          https://downloadcenter.intel.com/download/26141/Thunderbolt-3-Firmware-Update-Tool?product=89187
           
          I looked for the drivers that belong to the Razer Core and a found the following:
           
          http://drivers.razersupport.com/index.php?_m=downloads&_a=view&_m=downloads&_a=view
           
          On the following link you will find the proper drivers for the graphics card:
           
          http://www.gigabyte.com/products/product-page.aspx?pid=5915#dl
           
          Did you check with the manufacturer of the Razer Core in order to find out if there is a possible work around or a fix for this problem?
           
          http://www.razersupport.com/#community
           
          Which Windows version are you using?
           
          Please let me know the results of trying the steps above.
           
          NOTE: These links are being offered for your convenience and should not be viewed as an endorsement by Intel of the content, products, or services offered there.
           
          Any questions, please let me know.
           
          Regards
           
          Alberto
           

          1 of 1 people found this helpful
          • 2. Re: Intel NUC + Razer Core Error 43
            lemon93

            Hi Alberto

             

            Pardon my English if there are any grammar/spelling mistakes, as English is not my native language.

             

            Thank you for replying to my queries, however I've somehow managed to fix the issue and I believe the problem isn't with the NUC.

             

            I'm no IT expert but I can share my thought process in finding the problem and solution with the Razer Core/NUC.

             

            So here are the question I've asked myself and the solution I've came up in attempt to fix the error :

             

            Is there a problem with the NUC?

            I've been using the NUC for about a month prior to the purchase of Razer Core and didn't run into any issue with any of the drivers/ports. I've tested all the ports including the ThunderBolt and none of them seem to have any problems.

            So the error 43 issue occurred after the arrival of the Core after I connected the Core to the NUC. My NUC manage to detect the presence of the Core(the LED on the Core turned on) and GPU(the fan started turning) in the Thunderbolt window and Razer Synapse when I first connected them. I also managed to download and install the nVidia drivers.
            After installing all the required drivers for the GPU, an error 43 message appeared in the Device Manager under my GTX1080.

             

            I've followed some online tutorial and reinstalled several drivers, including the Thunderbolt firmware and NUC BIOS but the error 43 still persist.

            So to this stage I'm pretty confident that the problem isn't with my NUC, but with the Core itself.

             

            Maybe it's the problem with the Core?

            I tried to use the USB ports on the Core and it's working. Since the Core's LED is reacting accordingly to the Razer Synapse setting, also the GPU fan turned on, nothing seems wrong with the Core at this point too.

             

            The GPU is faulty?

            I've removed the GPU from the Core and inserted it into my desktop. Turning on the desktop immediately detects the GPU and without installing any drivers, it's fully usable(tried running Overwatch without issues).

             

            So to this point I can't seem to figure out the problem with the whole setup and I'm on the verge of giving up.

             

            I then fixed the GPU back into the Core and tried turning the NUC on again. The monitor flashed several times and both Intel HD and GTX1080 had error 43 in Device Manager.

            This is where I suspected that there might be softwares causing the issue with the display drivers.
            I also suspect that my desktop might have saved some preference settings onto the GPU itself, causing the GPU to react to hardware changes, but these are just guesses.

             

            External Software Issues?

            I restarted Windows, disabled my Wallpaper Engine(a live wallpaper software from Steam), reconnected the Thunderbolt wire on the NUC and right click on the desktop. This is where miracle happened.

            Both Intel HD Graphics and NVIDIA Control Panel settings appeared. I opened up the Device Manager and both the error 43 in Intel Iris Pro 580 and GTX1080 were gone. I quickly updated the drivers for GPU through GeForce Experience again and fired up Overwatch.

             

            I was thrilled to see GTX 1080 appeared on top of the settings menu in Overwatch. I restarted the computer several times and it seemed like the issue was fixed. At least that's what I thought.

             

            Couldn't use the display output ports on the GPU?

            When I tried to switch the HDMI port over from the NUC to Core/GPU, immediately both Intel HD and GTX1080 drivers crashed again. I've waited awhile but nothing appeared on the screen. I fixed back the HDMI cable into the NUC and went to Device Manager to check again. Both had error 43 again.

             

            Problem with the Core again?

            Thinking back, I realised the Core LED wasn't turned on when I was trying out Overwatch, only the GPU fan was turning.

             

            At this point I suspected that the whole issue here, with error43 in GTX1080, is the Core might not have enough power to power the setup.

             

            I changed the power source of the Core from my power-strip/multi-outlets into a single power supply and turned on both the NUC and Core. I changed HDMI cable onto the Core/GPU and it worked.
            At first I was doubtful that it will work for long and restarted the computer with the HDMI cable still plugged onto the Core/GPU. Upon waking, there was only black screen(I could hear the Windows had fully started because I'm still able to hear Windows notification sound).

             

            External software preventing proper startup?

            I changed back the HDMI onto the NUC and went to display settings and saw additional display connected to the PC. I went ahead and uninstalled Duet Display(a software that allows to be displayed on an iOS device) and reconnected the HDMI to the Core/GPU and restarted.

             

            It turned on, displayed the desktop screen I was waiting to see. I double checked if there are any issues again by reconnecting the Thunderbolt and restarting the PC several times.

            Everything seems to be working perfectly now. All nVidia settings were in order and no more issues of the LED not turning on when in Overwatch.

             

            So what exactly is the problem?

            My guess is the insufficient power supply to the Core and external softwares that prevented the proper installation of drivers.

             

            -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

             

            So this is my thought process that went through for a few hours and finally fixed the problem.

             

            I urge future/potential Razer Core buyers to double check on the softwares that they installed and make sure they have enough power supplied to the Core when they do the setup.

             

            Edit : I am using Windows 10 Pro by the way

            • 3. Re: Intel NUC + Razer Core Error 43
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hello :
               
              No problem at all, your English is really good actually.
               
              Thank you so very much for providing all those details and troubleshoot steps you did in order to stop the 43 error from showing, we really appreciate you took the time to share all that information and we are sure it will be really helpful for us and for all the peers viewing this thread.
               
              Perfect, excellent, it is really great to hear the NUC the Razer core and the video card are all working fine, and yes, as you mentioned before the insufficient power supply to the Core and external softwares were the ones prevented the proper installation of drivers, and that seems to be the issue on this scenario, we are glad to hear is working now.
               
              Any questions, please let me know.

              Regards

              Alberto