1 Reply Latest reply on Jan 23, 2017 4:18 PM by Intel Corporation

    Problem with Android Things

    jariiiii

      Hi

       

      I'm tryingg to flash my Edison (mini breakout bord) with Android Things, but I'm getting error:

       

       

      FAILED (remote: invalid slot number)

      while executing command:

      fastboot     flash gpt partition-table.img     flash u-boot u-boot-edison.bin     flash boot_a boot.img     flash boot_b boot.img     flash system_a system.img     flash system_b system.img     flash userdata userdata.img     erase misc     set_active _a

      all other steps seem to go fine:

      target reported max download size of 117440512 bytes

      sending 'gpt' (33 KB)...

      OKAY [  0.008s]

      writing 'gpt'...

      OKAY [  0.078s]

      erasing 'u-boot'...

      OKAY [  0.488s]

      sending 'u-boot' (375 KB)...

      OKAY [  0.020s]

      writing 'u-boot'...

      OKAY [  0.104s]

      sending 'boot_a' (10362 KB)...

      OKAY [  0.352s]

      writing 'boot_a'...

      OKAY [  1.145s]

      sending 'boot_b' (10362 KB)...

      OKAY [  0.351s]

      writing 'boot_b'...

      OKAY [  1.163s]

      sending sparse 'system_a' 1/5 (114685 KB)...

      OKAY [  4.436s]

      writing 'system_a' 1/5...

      OKAY [ 22.742s]

      sending sparse 'system_a' 2/5 (114573 KB)...

      OKAY [  4.287s]

      writing 'system_a' 2/5...

      OKAY [ 13.628s]

      sending sparse 'system_a' 3/5 (114338 KB)...

      OKAY [  4.339s]

      writing 'system_a' 3/5...

      OKAY [ 14.041s]

      sending sparse 'system_a' 4/5 (114646 KB)...

      OKAY [  4.452s]

      writing 'system_a' 4/5...

      OKAY [ 17.364s]

      sending sparse 'system_a' 5/5 (40618 KB)...

      OKAY [  1.546s]

      writing 'system_a' 5/5...

      OKAY [  6.658s]

      sending sparse 'system_b' 1/5 (114685 KB)...

      OKAY [  3.937s]

      writing 'system_b' 1/5...

      OKAY [ 22.739s]

      sending sparse 'system_b' 2/5 (114573 KB)...

      OKAY [  3.842s]

      writing 'system_b' 2/5...

      OKAY [ 13.614s]

      sending sparse 'system_b' 3/5 (114338 KB)...

      OKAY [  3.846s]

      writing 'system_b' 3/5...

      OKAY [ 14.035s]

      sending sparse 'system_b' 4/5 (114646 KB)...

      OKAY [  3.859s]

      writing 'system_b' 4/5...

      OKAY [ 17.340s]

      sending sparse 'system_b' 5/5 (40618 KB)...

      OKAY [  1.362s]

      writing 'system_b' 5/5...

      OKAY [  6.659s]

      sending 'userdata' (35529 KB)...

      OKAY [  1.201s]

      writing 'userdata'...

      OKAY [  4.776s]

      erasing 'misc'...

      OKAY [  0.132s]

      Setting current slot to 'a'...

      FAILED (remote: invalid slot number)

      finished. total time: 194.546s

       

       

       

      Any idea how I can fix this (device seems to be flashed to fastbook ok, as i see it in fast boot devices)?