10 Replies Latest reply on Feb 10, 2017 9:59 AM by Intel Corporation

    NUC6i5SYH SD Slot in Linux

    Lankyvaulter

      Has anyone gotten the SD card slot to work in Linux?  I have had no luck with Ubuntu (16.04 and 16.10).  Obviously I have an open question on the Ubuntu forums but was just wondering if anyone here had any luck.  Any flavor of linux would do, I have found nothing searching around forums and am just looking for some bread crumbs.

        • 1. Re: NUC6i5SYH SD Slot in Linux
          NucNucMoose

          Try updating the BIOS. That generation is known for having wonky SD card slots that don't always work or are recognized in any OS. I have that same model and had issues until I updated the BIOS.

          • 2. Re: NUC6i5SYH SD Slot in Linux
            Lankyvaulter

            Unfortunately I do have the latest BIOS update installed (0054).  Are you saying you are running Linux and the SD slot has worked out of the box for you?  Do you mind telling me what distro you are using?

            • 3. Re: NUC6i5SYH SD Slot in Linux
              NucNucMoose

              I'm not running Linux on it. It's using Windows. I was just saying that many people have had problems with the card reader not working in Windows and Linux. If you install a Linux distro that has been released/updated in the past few months, it should work. Also, check the BIOS settings for the SD card reader to make sure it's enabled, with read/write.

              • 4. Re: NUC6i5SYH SD Slot in Linux
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hello somedaysdreamers,

                In regard to your concern, at the following link, you will be able to see the list of supported OS for your Intel® NUC Kit NUC6i5SYH:

                Supported Operating Systems for Intel® NUC Products

                There you can confirm that our customers have reported as tested the following versions ofLinux: Fedora, Gentoo, Linux Mint, Lubuntu, and Xubuntu.

                You can test those versions if it is possible, and as you have an open question on Ubuntu Communities, you can also ask if they have tested the ones that I have provided.

                I am looking forward to hearing from you.

                Best regards,
                Angie

                • 5. Re: NUC6i5SYH SD Slot in Linux
                  John_BR

                  My system is: Ubuntu 14.04.5:

                   

                  http://releases.ubuntu.com/14.04/ubuntu-14.04.5-desktop-amd64.iso.torrent

                   

                  System:Host: NUC-John Kernel: 4.4.0-59-generic x86_64 (64 bit) Desktop: Gnome Distro: Ubuntu 14.04 trusty
                  Machine:Mobo: Intel model: NUC6i5SYB version: H81131-504
                  Bios: Intel version: SYSKLi35.86A.0054.2016.0930.1102 date: 09/30/2016
                  CPU:Dual core Intel Core i5-6260U CPU (-HT-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
                  Clock Speeds: 1: 499.992 MHz 2: 499.992 MHz 3: 499.851 MHz 4: 499.992 MHz
                  Network:Card-1: Intel Wireless 8260 driver: iwlwifi IF: wlan0 state: up
                  Card-2: Intel Ethernet Connection I219-V driver: e1000e  eth0 state: down (disconnected)
                  Graphics:Card: Intel Sky Lake Integrated Graphics
                  X.Org: 1.18.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz
                  GLX Renderer: Mesa DRI Intel Iris Graphics 540 (Skylake GT3e) GLX Version: 3.0 Mesa 11.2.0
                  Audio:Card: Intel Device 9d70 driver: snd_hda_intel Sound: ALSA ver: k4.4.0-59-generic
                  Drives:HDD Total Size: 750.2GB (0.7% used) 1: id: /dev/sda model: WDC_WD5000LPLX size: 500.1GB
                  2: id: /dev/sdb model: Samsung_SSD_850 size: 250.1GB  (not in use)
                  Partition:ID: / size: 47G used: 4.7G (11%) fs: ext4 ID: /home size: 113G used: 206M (1%) fs: ext4
                  ID: swap-1 size: 4.09GB used: 0.00GB (0%) fs: swap
                  RAID:No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
                  Sensors:System Temperatures: cpu: 29.8C mobo: 27.8C Fan Speeds (in rpm): cpu: 5273 mobo: 5273
                  Info:Processes: 233 Uptime: 2:11 Memory: 1080.4/7811.8MB Client: Shell (bash) inxi: 1.9.17

                   

                  SD card works perfect (tested with Transcend and Samsung SD and SDHC microSD with SD card adapter) under Ubuntu 14.04.5/64bits

                   

                  New versions of Ubuntu (like other OS's get buggy in the beginning and are fix by new releases.  I believe that 16.04.x will address most of the bugs.

                   

                  I can say that Intel wifi 8260 is still buggy (tested also with Lenovo laptop with Windows 8.1) but works for 802.11bgn (for 802.11a not stable, looks like a sync bug)

                   

                  Intel should keep a opened mind and work with Linux community because we support desktop development (which I believe is Intel's main business model) and we buy not only for personal use but also for businesses, and also we can help support platforms by open source development for Intel hardware.

                   

                  REF.:

                  TEDGlobal 2012: 'The more you give away the more you get back'

                  https://www.theguardian.com/technology/2012/jun/24/tedglobal-2012-the-more-you-give-away

                  • 6. Re: NUC6i5SYH SD Slot in Linux
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hello Lankyvaulter,

                    I was reviewing this thread and I was wondering if you were able to resolve the issue with the SD card slot.

                    If not, please check the following information:

                    http://askubuntu.com/questions/787088/ubuntu-16-04-does-not-detect-sd-card-reader

                    In addition to this, please bear in mind that the supported SD cards sizes are from 8GB to 128GB.

                    Please let me know how it goes.

                    Regards
                    Juan Carlos

                    • 7. Re: NUC6i5SYH SD Slot in Linux
                      John_BR

                      I just tested all the SD and microSD cards that I have here with Ubuntu 14.04.5 Kernel: 4.4.0-59-generic x86_64 (64 bit)

                      on the NUC6i5SYB version: H81131-504

                      with firmware SYSKLi35.86A.0054.2016.0930.1102 date: 09/30/2016

                       

                      Many are formated FAT, FAT32, NTFS, EXT4 and combination of partitions with them

                       

                      This is the result table:

                       

                      Sandisk1GBytesmicroSD with SD adaptorok
                      Sandisk2GBytesmicroSD with SD adaptorok
                      Nokia2GBytesmicroSD with SD adpatorok
                      AData2GBytesSDcard x50ok
                      KingStone2GBytesSDcard (SD-MO2G)ok
                      KingStone4GBytesmicroSDHC (SDC4)ok
                      Transcend4GBytesSDHCcard (SDC6)ok*
                      Patriot8GBytesmicroSDHC (SDC4)ok
                      SiliconPower   8GBytesSDHCcard (SDC6)ok
                      KingStone16GBytesmicroSDHC (SDC10)ok
                      Sandisk16GBytesmicroSDHC ultra (HC I)ok*
                      Samsung32GBytesmicroSDHC-EVO (HC I)ok
                      PNY128GBytes  microSDXC-Elite (HC I)ok**

                       

                      *  Two partitions (FAT and Ext4)

                      ** EFI system (FAT32/EXT4/SWAP)

                       

                      The only strange thing that happened in the beginning of the tests with de 1GByte microSD was that I used the original old adapter that came with it and it was not recognized.  Then I used a new Samsung adapter with the same microSD card and it worked.  After that I used the old SD adapter again and it worked too.  Very strange.

                      • 8. Re: NUC6i5SYH SD Slot in Linux
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        John_BR, thank you for sharing this valuable information; hopefully, it will be helpful for other peers with the same issue.

                        Lankyvaulter: please let me know if you need further assistance.

                        Regards,
                        Juan Carlos

                        • 9. Re: NUC6i5SYH SD Slot in Linux
                          Lankyvaulter

                          Apologies for going dark.  I was finally able to get to the bottom of the issues I was having.  I believe there is a physical defect with the microSD card or adapter.  As the naked microSD card works (sometimes) in it current role, and it only works sometimes when I plug it into other windows machines.  My regular sd card was formatted with exFat and I had not installed the necessary drivers to read it when I was testing the slot.

                          • 10. Re: NUC6i5SYH SD Slot in Linux
                            Intel Corporation
                            This message was posted on behalf of Intel Corporation

                            Hello Lankyvaulter,

                            Thank you for the update.

                            Please let me know if you need further assistance.

                            Regards,
                            Juan Carlos