5 Replies Latest reply on Jan 30, 2017 12:28 PM by Intel Corporation

    GSM shield not power up

    gau999

      Hello sir ,

      i'm working on GSM 900A shield which needs 12v power supply, and the shield has pin connection for Vin so that shield takes 12v from arduino board.

       

      in Arduino uno/mega board shield takes 12v supply from arduino board but in edison board gsm shield NOT powered up, also i have attached pictures of GSM shield with edison and arduino mega , kindly find the attachments

        • 1. Re: GSM shield not power up
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi gau999,

          Thank you for contacting us, we’ll try to help you use your GSM shield with the Edison. The first thing I notice is that you say that the shield takes 12V from the board. I looked at the specifications and the voltage rating of the shield is 5V (4.8V min and 5.2V max); this means that you shouldn’t experience problems powering the shield. I’d recommend you to check that the Edison expansion board is properly powered, so that it can supply to the shield. When power is applied to J1, the external power must be in the range of 7V to 17V.

          The shield also comes with a “power select” switch. Make sure the correct power supply is selected.

          Let us know if this resolves your issue.

          -Sergio
           

          • 2. Re: GSM shield not power up
            gau999

            Hello sir ,

             

            thanks for reply,

            i have tested GSM shield with 5v input supply to arduino board but it does not works with 5v supply , supply voltage to the GSM shield is through Vin pin of arduino. have a look on connection diagram with arduino board, please find the attachment.

             

            my problem is, i have connected GSM shield through Vin pin of edison so power LED of GSM shield should have to glow up but it does not ,

            if i select 5v supply power LED of GSM turn on but GSM does not work on 5v for GPRS connection that's why i have selected vin pin for powering up to GSM shield and tested with uno/mega

             

            • 3. Re: GSM shield not power up
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi gau999,

              Thank you for the clarification. If the shield you’re using must be powered using 12V then you’re going to have to power the shield externally, not with the power supply of the expansion board. Different GSM shields are made by different manufacturers so some may have a different input power. The connection diagram is very simple. The Tx and Rx lines should remain as in the image you attached. Now, with the shield unmounted from the expansion board, you can power the shield with an appropriate power input.

              You can see an image and a diagram on how to interface the shield here: http://www.instructables.com/id/Interfacing-SIM900A-GSM-Modem-with-Arduino/?ALLSTEPS .

              Let us know if you manage to get the GSM module working.

              -Sergio
               

              • 4. Re: GSM shield not power up
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi gau999,

                Do you still need assistance with this case? Let us know if there’s anything else we can help you with.

                -Sergio
                 

                • 5. Re: GSM shield not power up
                  gau999

                  Hello sir,

                  Thanks for your reply . i will check with external power supply to GSM shield and let you know

                  • 6. Re: GSM shield not power up
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Keep us updated on your progress.

                    -Sergio