8 Replies Latest reply on Feb 8, 2017 2:11 PM by Gussoh

    NUC6i3SY* cant boot UEFI but NUC6i5SY* can

    Gussoh

      Hi,

       

      I have about 5 NUC6I3SYK and I just bought a NUC6I5SYK to measure how much faster it is.

       

      I did an OS install image on the NUC6I5SYK and tried do run it on the other NUCs but they can't boot it. I tried many different things like booting from a USB drive and installing the system on a m.2 drive on the i5 and then moving the drive to the i3, neither seem to work. What happens is that if I just let it boot it says boot failure. If I press F10 and go to the boot menu and selects the UEFI M.2 disk or the UEFI USB Drive the screen flashes and goes back to the boot menu.

       

      I saw similar questions previously with similar symptoms that the boot menu flashes here but nothing about the difference between the i3 and i5.

       

      I have tried many different BIOS versions and they all seem to do the same. The 55 version which is the latest still cant boot UEFI on the i3.

      I have a custom boot graphics on the i3s, which does not seem to disappear even though the bios version changes. This is the only difference I can see between them. I could try and add that image to the i5 and see if it stops booting UEFI as well but it seems a bit far fetched. (Edit: I now tried adding the boot image to the i5 and it can still boot UEFI. So that made no difference.)

       

      I'm trying to run ubuntu 16.04.

       

      Anyone got any input on what I should try to make it work?

        • 1. Re: NUC6i3SY* cant boot UEFI but NUC6i5SY* can
          Gussoh

          I now tried the "Interactive EFI shell" and mounted the usb harddrive and ran grubx64.efi. That booted the USB harddrive from EFI. So it kind of works, but it just cant find what to run I guess. The i3 can boot the ubuntu EFI but it cannot do it automatically for some reason.

          • 2. Re: NUC6i3SY* cant boot UEFI but NUC6i5SY* can
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Intel offers limited support for Linux installation on Intel® NUC.
            Please check this link for troubleshooting information
            http://www.intel.com/content/www/us/en/support/boards-and-kits/000005499.html

            Does the installation work with a particular BIOS version?
             

            Allan.



             

            • 3. Re: NUC6i3SY* cant boot UEFI but NUC6i5SY* can
              Gussoh

              Thanks for the reply!

              I couldn't see any information in the troubleshooting information about any difference being between the i3 and the i5 or anything about UEFI really. Since I don't know what is causing this I cant tell for sure if it has any relation to which operating system it is but I cant see that it looks like it is caused by linux in any way. Linux has not even started and it works in the interactive efi shell.

              I have now tried to run it on four of the i3:s I have but they are all the same. I can do it manually with the interactive efi shell but it wont boot automatically.

               

              I have not yet found a BIOS version which works but I haven't tested any of the older versions. I could try one tomorrow. Do you or anyone have any suggestion of any specific version to try?

              • 4. Re: NUC6i3SY* cant boot UEFI but NUC6i5SY* can
                N.Scott.Pearson

                The issue has nothing to do with any differences that exist between the Core i3 and Core i5 SOCs. If you are using Windows 10, the image will be bound to the board on which it was installed and will not work on any other board, plain and simple.

                 

                ...S

                • 5. Re: NUC6i3SY* cant boot UEFI but NUC6i5SY* can
                  Gussoh

                  Hi Scott.

                  That could definitely be the case, but this is the only difference I can find between the computers. Apart from that they are identical. I could accept it easier if it would have been the other way around; That it is not working on one of the computers and working on all the others, then there would just have been a problem with that one. But now it is working on one computer and not the others which indicates that there is some kind of bug. I cant really return 5 computers saying they are broken.

                   

                  It would be super if anyone could confirm my findings. I could definitely still be doing something wrong but all my tests indicate that it works on one computer (the i5) but not on the others. It is the same two USB drives I've tested in all of them. I could try and make a new and try it in an i3 first, and see if it, after that, can only boot on that i3 but since it works in interactive efi shell on the i3 I don't think that is very likely.

                  • 6. Re: NUC6i3SY* cant boot UEFI but NUC6i5SY* can
                    Gussoh

                    I still haven't made a new usb bootable drive and made sure I first tested it on an i3. Is there any reason to think that that would make any difference since it works if I start it manually trough the interactive efi shell? I could try it on another computer. If the bootable drives I have which does not boot on the i3:s boots on any other computer I can rule it out that they are "bound" to the one i5 nuc I have I guess.

                     

                    All suggestions of what to try are greatly appreciated.

                     

                    I'm also trying to find a way to revert all BIOS changes. I have made changes to the BIOS (eg boot image) and I cant find a way to clear it to default settings. New BIOS versions do not seem to overwrite the settings and reverting to "defaults" does no difference.

                    • 7. Re: NUC6i3SY* cant boot UEFI but NUC6i5SY* can
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      By running the BIOS recovery method to an earlier version you can change the BIOS configuration.

                      http://www.intel.com/content/www/us/en/support/boards-and-kits/000005532.html

                      Allan.

                      • 8. Re: NUC6i3SY* cant boot UEFI but NUC6i5SY* can
                        Gussoh

                        Thank you.


                        Regarding the problem I'm switching all computers to i5:s and legacy bios instead. That seems to work fine for all of them.

                         

                        Still havent found the cause of the problem with the i3:s.