6 Replies Latest reply on Jan 10, 2017 9:20 AM by gr_ukw

    Miracast not working on STK1AW32SC (10/2016, Z5-8330) or STK2M3W64CC (10/2016)

    gr_ukw

      Miracast is not working on STK1AW32SC (10/2016, Z5-8330) or STK2M3W64CC (10/2016), tried 3 of each...but working on STK1AW32SC (01/2016, Z5-8330). Latest drivers (WLAN, Chipset, Graphics, DirectX 12, Win 10-Updates) installed. It looks the decive was ready to display the screen and would do it now, but then it says "an error occured". Source was Lenovo Ultrabook and Lenovo M93P running Windows 10. There seem to be minor differences in the ICS's hardware-components between the versions.
      Has anybody made successful Miracast-Connections to the newer (late summer/fall 2016) Intel Compute Sticks with Z5-8330 or the STK2M3W64CC?

        • 1. Re: Miracast not working on STK1AW32SC (10/2016, Z5-8330) or STK2M3W64CC (10/2016)
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello gr_ukw,

          In regard to your concern, after an extensive research, I was able to confirm that Miracast it is not supported by these Intel® Compute Sticks (Intel® Compute Stick STK1AW32SC & Intel® Compute Stick STK2m3W64CC).

          In order to have a similar feature, the Compute Sticks as a minimum requirement must have the feature of Intel® WiDi, and as you can confirm on the product specifications this feature is not listed.

          Intel® Compute Stick STK1AW32SC

          Intel® Compute Stick STK2m3W64CC

          I do apologize for any inconvenience that this situation might cause you.

          Although, you can refer to the following links, in order to get additional information or support for Miracast on Windows 10:

          Project to a wireless display with Miracast (For Windows 8.1 or Windows 8.1RT)

          Windows Support (additional support in order to confirm Windows 10 compatibility and Support for Miracast)

          I am looking forward to hearing from you.

          Best regards,
          Angie
           

          • 2. Re: Miracast not working on STK1AW32SC (10/2016, Z5-8330) or STK2M3W64CC (10/2016)
            Repeat%20Offender

            windy.pngSummary information: it worked with STK1AW32SC running Windows 10, both in source (sender) and sink (receiver) mode.

             

            Long story: Ever since I saw the thread STK1AW32SC - Projecting to this PC I wanted to test out this capability. I have a Samsung 50HU6950 smart TV, and in my view screen mirroring is its only useful smart feature. When an undergraduate wants to show you what's on his smart phone, he can either email it so you can open it on your computer, or with a smart TV you can use screen mirroring as long as his smart phone isn't an Apple product. Since I also have a Vizio M302NV that I can use as the monitor for the source PC, I tried using my STK1AW32SC, system information posted in the thread Painful internet explorer performance connected to the Vizio as the source and the Samsung with input set to screen mirroring as the sink. It worked! Thus if a student comes by with a reasonably up-to-date non-Apple laptop I can see what he's got on the big screen.

             

            I also tried going through the login sequence without a monitor connected via HDMI, then connecting to the Samsung the same way using only a memorized sequence of keystrokes. Since the Compute Stick is designed to be used in embedded contexts as well, it worked, see the thread Blind login  .

             

            But just like you I wanted to use my STK1AW32SC connected to my Samsung monitor as the sink. I figured it should be possible with my i7-4770 computer running Windows 8.1 connected to my Vizio as the sink. Unfortunately when trying to connect via <WINDOWS>+C (to bring up the charms bar) ->Devices->Project the "add a wireless display" link didn't show up. It turns out that there are a lot of things that can make this happen, such as hardware or drivers that are too old (but 2014 isn't too old) or there can be some things associated with virtual networking IIRC that can possibly be disabled through (on Windows 8.1) Start->Control Panel->Device Manager, then expanding the Network Adapters entry and selecting Show Hidden Devices from the View menu and then right-clicking on various entries and uninstalling them and seeing if anything helps.

             

            Another thing to try is to right-click the network icon in the system tray and selecting Open Network and Sharing Center where you can click on the Change Adapter Settings link then right-click WiFi and choose Properties where now you can try and zap some of the things in the box that say This connection uses the following items.

             

            Of course none of the above worked for me, so if found out that you can run dxdiag and tell it to puke its output to a *.txt file. In that file I found the line "Miracast: Not Supported by Graphics driver" and googling that phrase and found out shortly that NVIDIA doesn't support Miracast for cards before 970 GTX (possibly 960 GTX or 750 Ti) but certainly not my 650 GTX. Somebody said that his workaround was to remove the graphics card, set the BIOS to use the CPU's built-in GPU, and uninstall the NVIDIA drivers. Since this was a lot of work to do (and undo) I figured I would wait until the next time I went to the local university library where they have table set up with Windows 10 PCs where the books used to be and also what seems to be 48 in 1080p monitors in the nooks along one wall. I could use my STK1AW32SC on one of the wall monitors as the sink and one of the Windows 10 PCs as the source to attempt a connection.

             

            However later that day I saw your post so today I thought instead I would try the procedure of getting rid of the NVIDIA card on my i7-4770 PC. It was a little easier than I would have thought because Windows Update figured out that I needed the drivers for the on-chip Intel graphics all by itself. The add a wireless display link now showed so I tried using the i7-4770 connected to the Vizio as the source and the Samsung as the sink. This didn't work, but I still tried the i7-4770 & Vizio as source but this time my STK1AW32SC connected to the Samsung as the sink. This did work, but awkwardly. After setting up the sink to receive, and then going through "add a wireless display" on the source, I got the notification on the sink, so I clicked on OK and got to a screen on the sink that said "HASWELL is about to project" and on the source it said "DESKTOP-9LCCLCK is ready for you to connect wirelessly" but I didn't get any connection at that point. So I right-clicked on the device in the source and removed it, then tried "add a wireless display" again and it worked the second time. After repeated experiments, always the second time, never the first.

             

            By default it connects in extend mode, let me show you a picture:

             

            Oops, maybe the image came out on top of the post. As you can see it looks like it's setting up a 2276x1280 logical display on the 4K sink despite the source and video being 1920x1080. The video, which was expanded to full screen mode on the sink monitor, was pretty smooth but the sound as played on the sink was choppy.

             

            So Miracast wasn't all that reliable but it was (barely) capable. I hope sharing my experiences with you has helped.

            • 3. Re: Miracast not working on STK1AW32SC (10/2016, Z5-8330) or STK2M3W64CC (10/2016)
              gr_ukw

              Hello Angie,

              thanks for your reply. I also did a search inspired by your response and indeed found that the Z5-8300 is listed as WiDi-compatible and its direct successor Z5-8330 is not! But that is obviously the trap i fell into:

              I tested it out with the STK1AW32SC (Z5-8300) I had at hand , Miracast works fine! Because of this  I ordered the SAME product STK1AW32SC (5 pieces) and due to a modernized processor this feature got lost?
              How should I guess that???

               

              The same list shows the m3-6y30 (processor of the STK2M3W64CC) as WiDI-enabled. I also got 7 of these! Altogether I spent ca.3.000 $ and a LOT of worktime to make these things work.

              So I really hope we can make at least the STK2M3W64CC work as a Miracast-sink.

               

               

               

               

               

              STK2M3W64CC

               

              • 4. Re: Miracast not working on STK1AW32SC (10/2016, Z5-8330) or STK2M3W64CC (10/2016)
                gr_ukw

                Hello unknown writer,

                 

                thanks for this really long answer! For me it would be interesting to know wthat kind of processor is in your STK1AW32SC: Atom Z5-8300 or Z5-8330?
                (In my first post I made this description-error in the first line : STK1AW32SC (01/2016, Z5-8330). Correct is: STK1AW32SC (01/2016, Z5-8300)  ).

                 

                Kind regards,

                 

                Günther

                • 5. Re: Miracast not working on STK1AW32SC (10/2016, Z5-8330) or STK2M3W64CC (10/2016)
                  Repeat%20Offender

                  It's an x5-Z8330 running Windows 10 x64; I posted my system information in the thread Painful internet explorer performance . As you can see from my post there are a lot of things that can go wrong. The sink system needs the latest update for Windows which doesn't come with the Stick. You have to go to Windows Update to make sure it gets installed. Look mine up in the above link. Also I've got the latest BIOS. When you installed the Intel drivers did you install them in the order Cherry Trail, TXEI, GFX, BT, Wireless as recommended? Do you have a clean installation on your STK1AW32SC? Have you tried to check whether one Compute Stick can Miracast to another?

                   

                  Since Miracast comes with Windows nowadays you might be able to try to get hints on a Windows forum. As a last resort you might try installing Windows 10 x64 on one or two Sticks, closely following the directions in How-Tos - Linuxium to see whether you can reproduce my results. As I tried to point out in my post above, the process looked like it was getting hung up with the blue screen that said something about being ready to connect on the sink system, and I had to go to the source system and remove the sink device and search for it again before the connection worked.

                  • 6. Re: Miracast not working on STK1AW32SC (10/2016, Z5-8330) or STK2M3W64CC (10/2016)
                    gr_ukw

                    Thanks. That you made it finally work on the Z5-8330 is helpful Information. I will go through all you hints. It might take up to 24h before I can report results.
                    Günther