5 Replies Latest reply on Jan 18, 2017 3:17 PM by Intel Corporation

    Disable g_mutli / alternatives?

    Peter-H

      I'm trying to remove g_multi from my setup but I can't get the USB to work without it.

      Alternatively what is the configuration to disable all g_multi features?

       

      I will be running the Edison module in USB host mode only.

      I've compiled a custom image with minimal modifications(added one module for an external ethernet driver).

       

      At this stage it works, though I would like to remove the mass storage and usb-ethernet-device functionality(which I believe is served by the g_multi module).

       

      My first approach was to disable the g_multi module completely.

      After a reboot lsusb did no longer work(unable to initialize libusb: -99).

       

      Then I tried modprobe g_multi after which lsusb worked.

      On the same running instance I ran rmmod g_multi and now the USB system still works.

       

      I've looked at the loaded modules.

      Thsese were loaded from start:

      smsc95xx               31910  0

      bcm_bt_lpm             13708  0

      bcm4334x              587105  0

      And these were added after modprobe g_multi

      usb_f_acm              14335  1

      u_serial               18582  1 usb_f_acm

      g_multi                70924  0

      libcomposite           39238  2 usb_f_acm,g_multi

      After rmmod g_multi only that module was unloaded.

       

      Now I tried to enable g_multi but removed all options from /etc/modprobe/g_multi.conf

      After a reboot there was no longer a usb0 network device as wanted.

      But this time the USB system did not work at all.

       

      What would the best approach to replace/reconfigure g_mutli so that it doesn't generate usb mass storage device nor a usb0 network device?

      And still have the usb system working?