4 Replies Latest reply on Jan 31, 2017 1:49 PM by Intel Corporation

    Kodu Rendering Issue on HD 620 (i5-7200U)

    KabyLake

      Hi

       

      I have a Lenovo Yoga 710 running Windows 10 which has rendering issues when running Kodu (latest version 1.4.164.0).  This model does not have dedicated graphics from nvidia - it uses the integrated graphics on the CPU.  I have downloaded all of the latest drivers from Lenovo and Microsoft's Windows 10 update but I still have the issue.  The latest Intel graphics drivers from Lenovo is 21.20.16.4526 and I have tried Intel's generic graphics drivers 15.4512.4542 and the beta 4552 but this does not resolve the issue.

       

      System Setup Information:
      -----------------------------------------

      System Used: Lenovo Yoga 710
      CPU SKU: i5-7200U
      GPU SKU: HD620
      Processor Line: U
      System BIOS Version: CIUY7 - 2XCN25WW (v2.00) (latest that Lenovo update provided from shipped 2XCN20WW(v1.02)
      CMOS settings:
      Graphics Driver Version: 21.20.16.4526 (from Lenovo) and Intel's Generic Graphics Drivers 15.4510.4542 and the beta 15.4512.4552
      GOP/VBIOS Version: 9.0.1054
      Operating System: Windows 10
      OS Version: Windows 10 version 1607 (Anniversary Update)
      API: DirectX 9c and Shader Model 2.0 (based on system requirements listed Kodu Forum | Kodu Technical FAQ)
      Occurs on non-Intel GPUs?:  I don't know

      Steps to Reproduce:
      -------------------------------
      1. Run Kodu 1.4.164.0
      2. Try environments shipped that have trees e.g. Fortress Defence
      3.
      4.
      5.
      6.
      7.
      8.
      9.
      10.

      Expected Results:
      -------------------------------

      Trees not rendering across the screen

      Actual Results:
      -------------------------------

      See screenshot + video

      Additional Information:
      -------------------------------

      Output from intel HD Graphics Control Panel

       

      Report Date: Sunday, January 8, 2017

      Report Time [hh:mm:ss]: 4:22:26 PM

      Driver Version: 21.20.16.4526

      Operating System: Windows* 10 Home (10.0.14393)

      Physical Memory: 8035 MB

      Vendor ID: 8086

      Device ID: 5916

      Device Revision: 02

      Graphics Output Protocol (GOP) Version: 9.0.1054

      Current Resolution: 1920 x 1080

       

      Processor: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz

      Processor Speed: 2712 MHz

      Processor Graphics in Use: Intel(R) HD Graphics 620

      Shader Version: 5.1

      OpenGL* Version: 4.4

      OpenCL* Version: 2.1

       

      * Microsoft DirectX* *

      Runtime Version: 12.0

      Hardware-Supported Version: 12.0

       

      * Devices connected to the Graphics Accelerator *

       

      Active Displays: 1

       

      * Built-in Display *

       

      Display Type: Digital

      DDC2 Protocol: Supported

      Gamma: 2.2

      Connector Type: Embedded DisplayPort

      Device Type: Built-in Display

       

      Maximum Image Size

      Horizontal Size: 12.2 inches

      Vertical Size: 6.69 inches

       

      Supported Modes

      1920 x 1080 (60p Hz)

       

       

      I’ve tried changing all the options in the Kodu settings programme (turning off all visual effects and graphics quality) but this doesn’t help.

       

      I have reported the issue to the Kodu team, but suspecting this is a graphics rendering issue I have reported it here as well.

       

      Thanks in advance for your help.

       

      Message was edited by: Jonathan Wrobel