4 Replies Latest reply on Feb 13, 2017 2:04 AM by MartyG

    SR300 - cannot install DCM, cannot use for Hello

    AnsorgJ

      Hello all, hope I'm at the right place here. I have a SR300 in form of Creative BlasterX Senz3D. I had it installed and working properly for a couple weeks.

       

      Today My PC acted up, after a power loss something was corrupt and it would not boot, got that repaired and fixed and all is well - all but the 3D cam :-(

       

      I have uninstalled and reinstalled the software that came with the cam from Creative and device manager looks like this

      2017-01-05 20_31_02-Geräte-Manager.png

      At that state, the audio does work. The RGB camera also seems to work. I can get an image from the RGB cam in a Software like OBS or Multisplitter.

      I get a "no camera connected" in the Windows 10 Camera app or in Windows Hello Setup.

       

      I remember (old screenshot) that previously I had a third imaging device " Intel(R) RealSense(TM) Camera SR300 Virtual Driver - this is missing now.

       

      Also, I tried to install the DCM (hoping this would make some difference) but it tells me my camera is not compatible.

       

      What am I missing here? How to get the Cam fully working again?

       

      Thanks!

        • 1. Re: SR300 - cannot install DCM, cannot use for Hello
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Ansorg,

          Thank you for reaching out.
          I would suggest you two things,

          1. Make sure to try with a different USB 3.0 port on your computer, make sure not to use a USB hub, connect your camera to a dedicated USB 3.0 port.
          2. Also, try downloading the USB drivers for your chipset and then try to connect the camera again. I’m thinking that the original issue (the power loss) might have caused some other issues that weren’t fully solved, one being the USB drivers.
          Let us know your results once you try these suggestions.

          Regards,
          -Pablo
          • 2. Re: SR300 - cannot install DCM, cannot use for Hello
            AnsorgJ

            Turned out I had to totally reinstall the OS. And now everything is back to normal. Without installing any specific drivers. Was not aware that the SR300 is supported by W10 out of the box!

            • 3. Re: SR300 - cannot install DCM, cannot use for Hello
              TomBombay

              I actually fixed this issue without reinstalling Windows 10 after several rounds of reinstalling and switching USB ports with no luck.

               

              Here's What I Did:

               

              I uninstalled the camera devices from device manager by right clicking on the individual items.

               

              I uninstalled the camera software. I restarted.

               

              I disabled my anti-virus software. I deleted my Windows Hello recognition information. I unplugged the camera. I reinstalled the software.

               

              After the restart, I plugged the camera back in.

               

              I right clicked on one of the camera devices in the device manager (still not showing up properly) and said update driver. I let it automatically find the driver. After that, everything was properly setup with the virtual driver in Device Manager and the camera is properly recognized with the Windows 10 Camera app instead of giving me an error.

               

              Which one of these steps is critical to making the camera work again? I have no idea but I hope this helps somebody. It was very frustrating to not have this camera work properly.

              1 of 1 people found this helpful
              • 4. Re: SR300 - cannot install DCM, cannot use for Hello
                MartyG

                Thank you very much for methodically documenting your procedure for others to follow, Tom!  Sometimes, suggestions for fixes can sound almost like mythical rumor (like "blow your breath on the pins of your Nintendo cartridges to make them work better), so it's really useful to have a set of clear steps to follow.  Thanks for sharing!