6 Replies Latest reply on May 7, 2017 4:22 AM by fnoop

    Joule fails to boot after several successful boots

    medavies

      I recently got an Intel Joule 570x development kit and I noticed that often it hangs on booting. I've noticed after being unplugged it usually boots successfully a few times.

       

      After a few reboots from the OS (I use Ubuntu 16.04), the board will not boot at all. From the serial connection it stops at

       

      Board Name = Joule DVT3

        MRC REVISION ID 1.52.27

      MMRC REVISION ID 1.09

       

      And does not display anything past that. I usually have to unplug the device and plug it back in but sometimes that doesn't even work. I've tried unplugging all peripherals with no luck. And this behavior doesn't seem to be systematic in that it can happen when being plugged in (cold boot), or from an OS reboot.

       

      My best guess so far is that 1) my power adapter I ordered from Amazon might not be very stable, 2) there is a bios problem, or 3) there is a hardware problem with my board.

       

      Any thoughts?

      Thanks

        • 1. Re: Joule fails to boot after several successful boots
          floydg

          I am also running Ubuntu.

           

          Do not see this issue, you are describing.

           

          Some ideas, to possibly isolate the issue.

           

          Some ideas (my test setup):

          verify the Intel Joule SOM is firmly installed on the TuChuck Development board

          verify the heat sink is installed (is system getting hot?)

          remove the micro SD Card if it is not being used

          connect HDMI video to display

          Connect USB serial Bridge (Hyper-terminal 115KB 8 N 1)

          Connect USB hub with (Mouse and keyboard)

           

          Notification with LEDs:
          MAIN PWR LED is active when power is supplied

          LEDS (Green) GPIO100 - on, delay 500ms,  GPIO101 - on, delay 500ms, GPIO102- on, delay 500ms, all off (walking LED test) on bootup.

          fourth LED GPIO103 is active when system BIOS Boot options can be selected.

          Also the Blue wireless LEDs flicker on power up.

           

           

           

          Scenario #1)

          For power try: plug-in USB 3.0 Type C connector (which provides power), and hyperterminal displays boot process.

          and see if this is more reliable as a power up.

           

           

          Scenario #2)

          plug-in Wall Wart (which provides power), and hyper-terminal displays boot process.

          I am using the wall wart from the Intel Edison Kit: MOSO - MSP-C2000IC12.0-24W-zz

          0.8A max, output 12V 2A

          • 2. Re: Joule fails to boot after several successful boots
            medavies

            Hey thanks for the reply. Unfortunately, no luck resolving this. Here are some observations I made:

             

            - I tried powering it through the USB-C port. Things seemed to be working but eventually it did start hanging again. I have not observed the system hanging when powered on the first time after being off for a while (hour or two).

             

            - I am fairly confident it's not a thermal issue. There are times when it is booted and running software and the heatsink is noticeably warm and everything is fine. When it hangs on boot, the heatsink is usually cooler. I realize that's not a rigorous test, but I still think I'd be observing something like random shutdowns if the SoM was overheating. Also, the SoM was pre-seated on the development board and isn't noticeably loose.

             

            - When it hangs, the Power and GP100 LED are on, no others are. Additionally, the blue wireless LED does not flash when it hangs. Often times when it does successfully boot, it prints the board name, MRC and MMRC revision, and BIOS ID twice; and sometimes it doesn't.

             

            - This is also not limited to running Ubuntu, I observed this same behavior when I had Windows IoT installed.

             

            - I think I mentioned this, but this behavior is also independent of peripherals (I've tried various configurations of USB devices - keyboard and flash drive, and micro-hdmi connector for a display). I currently only have the USB-C cable plugged in for power, and a micro-USB cable to attach my computer for access to the hyper-terminal. Also, I have removed the MicroSD card with no change.

             

            At this point I am fairly sure it's a hardware issue and may have to see if I can return it for a replacement.

             

            Thanks again for your feedback. If you have any other ideas, please let me know!

            • 3. Re: Joule fails to boot after several successful boots
              floydg

              The following is an interesting bread crumb:

              "When it hangs, the Power and GP100 LED are on, no others are."

               

              And may lead to where in the boot process the system is having issues (halting).

              I am not sure aware of a boot-up state diagram which discusses the LED notification status. Maybe Intel can shed some light on this process.

               

              Also I am not sure if you stated whether or not you are running (or have upgraded) to the new BIOS.

               

              This does sound like it maybe an intermittent HW issue.

               

              based on this issue, is it possible to get:

              Open-source UEFI-compliant BIOS for the Intel Joule.

               

              I did not find this with searches on the web: Does anyone know where the link is to this source code?

              • 4. Re: Joule fails to boot after several successful boots
                medavies

                Hey,

                 

                I have updated my BIOS to the latest version on Intel's site (found in their user guide). I'd be interested in seeing their BIOS code as well if it is open-source.

                 

                I have submitted a support ticket and plan on just replacing the device to resolve this issue. It's pretty clear this behavior is not something that should happen under common configurations (including mine) and there isn't much else I can look at to debug.

                 

                Thanks again

                • 5. Re: Joule fails to boot after several successful boots
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi Medavies,

                  I believe we’ve already contacted you via email. Thank you for letting us know that you opened an email ticket. Feel free to ask any other question you may have in there.

                  Regards,
                  -Pablo

                  • 6. Re: Joule fails to boot after several successful boots
                    fnoop

                    Hi, what was the resolution to this, if any?  I have the same thing, it randomly hangs on boot and it's really irritating.  Unplugging the power doesn't always help and it seems random.  I don't think it's hardware as it works perfectly otherwise, ditto thermal.