3 Replies Latest reply on Dec 30, 2016 10:07 AM by Intel Corporation

    Intel(R) Rapid Storage Technology enterprise fails after Windows 10 upgrade

    WDS

      I have an ASUS motherboard based system with an Intel C600 Series Chipset SATA RAID Controller where after upgrading from Windows 7 to Windows 10 the RSTe program (Start->Intel->Intel(R) Rapid Storage Technology enterprise) fails to run with the error:

      An unknown error occurred while running this application.  If the problem persists, please restart your computer or try reinstalling the application.


      If I click on "More help" I get:

      An unknown error occurred while an operation was in progress.  The operation could not be completed.

       

      This worked fine before the Windows 7 to 10 upgrade.  I fiddled with the program compatibility settings and running as administrator but nothing worked.

       

      So off I went and looked up the new version which I downloaded from here:  Download Intel® Rapid Storage Technology (Intel® RST) RAID Driver

       

      The installation of that fails:

      The setup program ended prematurely because of the following error:  This platform is not supported.

       

      Is there a C600 specific version somewhere that I should be using?  I tried  Download Intel® Embedded Server RAID Technology 2 (ESRT2) RAID driver for Windows*  (which mentions the C600) but that appears to just be the drivers, not the RSTe program.

       

      Thanks for any help!