1 2 Previous Next 17 Replies Latest reply on Jan 29, 2017 1:01 AM by Repeat%20Offender

    Attempting to dual boot ubuntu

    Repeat%20Offender

      I tried following linuxium's instructions Dual booting Ubuntu and Windows on the CS125 Intel Compute Stick (STK1AW32SC) - Linuxium  to dual boot Windows 10 x64 and ubuntu on a STK1AW32SC but eventually ran into the low graphics issue xorg - How to fix "The system is running in low-graphics mode" error? - Ask Ubuntu which seems to be a software issue that prevents X windows from loading and has many potential causes.

       

      The Windows 10 x64 went pretty much OK, although the instructions about wiping out all the disk partitions might have been more specific about really wiping every last one out, no matter how scary it looks, and installation and updates might have gone more smoothly if I had known about the recommendation to remove the Micro SD card beforehand.

       

      At this point I could run ubuntu in live DVD (actually live USB) mode, and sound and WiFi worked, although that SanDisk Ultra PLUS microSDXC UHS-1 64 GB card didn't seem to be visible to ubuntu. My bad, as SanDisk 64 GB cards were already called out as not working in ubuntu. On installing ubuntu, I got to the stage where you update and upgrade ubuntu but I didn't see the dialog box at 6:22 of Dual booting on the CS125 Intel Compute Stick (STK1AW32SC) - YouTube and on reboot I got to the low graphics screen. Oh, I guess I got through upgrading of the kernel and the reboot at 6:53 was where things went south. So there are two ways forward that I can imagine: either to figure out what was different in my procedure from linuxium's that worked or to be able to perform diagnostics from the from live DVD mode or recovery console so I could get help to fix the problem.

       

      The first path seems the more promising. Differences were that I had a newer BIOS than the date of the video, having upgraded about two weeks ago, that I used the zesty-desktop-alpha-131216-linuxium.iso - Google Drive linked to on linuxium's web page, and that rufus complained about missing a couple of files that it went out on the internet and downloaded for me. This last difference may be the problem in that if the staging directory with rufus and the ISO already contains the rufus files subdirectory, rufus will silenty use those files, so the ones it downloaded for me may be different from the ones used in the video.

       

      As for the second path, I had an undergraduate over yesterday and even he couldn't figure out how, in recovery console mode, to change the graphics mode so the leftmost 128 pixels didn't get chopped off, connect to internet via the WiFi so all the suggestions about using apt-get could be tried, or to save the output seen on the recovery console so that I could post it back to kind people who were trying to help me.

        • 1. Re: Attempting to dual boot ubuntu
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Repeat%20Offender ,

           

          Thank you for posting in our Intel Communities.

           

          I would like to let you know this configuration is not officially supported by us, you can test it for sure, but it would be done under your own responsibility/risk.

           

          My recommendation would be to check if other users here have performed this and can assist you with the inquiry.

           

          Hope you can get this solved, if you can, it would be great to report it for future questions from other users

           

          Regards,
          Esteban C

          • 2. Re: Attempting to dual boot ubuntu
            linuxium

            How much space did you allocate to the Ubuntu partition (see 5:35 in the video)? If you boot from the LiveUSB how big is the Ubuntu partition currently and how full is it (c.f. 'df' command)?

            • 3. Re: Attempting to dual boot ubuntu
              Repeat%20Offender

              I only allocated 8.5 GB; later I read that I was supposed to allocate at least 8.6 GB. But that was only a part of the problem: since things weren't going well I tried installing version 16.10 and only later did I read on https://liliputing.com/2015/07/install-ubuntu-14-04-lts-on-the-2gb-intel-compute-stick.html  that I should have used efibootmgr to clean up the boot entries. I got to a setup where I couldn't boot anything and ended up reinstalling Windows x64 from scratch.

               

              So today I tried again allocating 10.0 GB with the version zesty-desktop-alpha-281216-linuxium.iso - Google Drive  and this time I skipped upgrading the kernel as it seemed to already have the latest kernel according to uname -a. Unfortunately after I rebooted without the USB stick inserted, I couldn't boot to anything successfully. The <F10> menu shows only ubuntu and booting to that results in no bootable device detected. So I seem to have hosed my Compute Stick once again and am hoping for guidance on making forward progress without reinstalling Windows. If I use the Windows recovery disk (actually USB stick) that I made will I at least be able to avoid the lengthy Windows update part of reinstallation?

               

              EDIT: I tried 32-bit Windows instead of 64-bit Windows at the <F2> BIOS screen and it successfully booted to ubuntu. Still can't see how to boot to Windows. Selecting Windows boot manager at the GRUB screen only cycles back to the GRUB screen. Playing a 4k video in full screen mode in firefox now doesn't lock up the system, but it makes it unstable. For example switching back to normal window size creates a situation where moving the mouse cursor around the screen leaves behind a trail of cursors dancing happily that only go away when a window is moved over them.

              • 4. Re: Attempting to dual boot ubuntu
                linuxium

                When you re-installed Windows X64 was the BIOS was set to 64-bit? And also when you then installed my Zesty ISO it was still set to 64-bit? If so then it sounds like the NVRAM and ESP are out of sync but this is not a major drama. All you need to do is boot from the Ubuntu LiveUSB again and fix it using the 'efibootmgr' command. However if you have subsequently changed the BIOS to 32-bit and Ubuntu boots it sounds like Ubuntu installed as 32-bit so that doesn't make sense. Can you set the BIOS back to 64-bit and re-install Ubuntu from the ISO? This time when asked the type of installation, select the option to re-install Ubuntu (rather than upgrade or erase disk and install Ubuntu). If having re-installed Ubuntu as 64-bit and there is nothing to boot after the installation reboot, then here are the steps to fix the NVRAM:

                 

                1. Start with the ICS switched off.
                2. Connect your LiveCB USB.
                3. Power on the ICS and press F10 and boot from the USB.
                4. Open a terminal windows and enter:
                sudo su -
                # if efibootmgr isn't already installed enter:
                apt-get install efibootmgr
                5. Remove any boot entries that may have been created through the earlier install or attempts to get things working by entering:
                for BOOTENTRY in 0 1 2 3 4 5 6 7 8 9
                do
                efibootmgr -b ${BOOTENTRY} -B
                done
                6. Create an Ubuntu boot entry by entering:
                efibootmgr -c -d /dev/mmcblk0 -p 1 -l \\EFI\\ubuntu\\grubx64.efi -L Ubuntu
                7. Reboot and press F10 and boot from the newly created Ubuntu entry.

                 

                 

                 

                 

                 

                • 5. Re: Attempting to dual boot ubuntu
                  Repeat%20Offender

                  I was pretty sure that the BIOS was set to boot 64-bit Windows at all times, so I tried the loop you offered. Now 32-bit Windows in the <F2> menu boots to no bootable device detected, Android boots to Windows, and 64-bit Windows booted once to Windows and once to no splash screen. So I guess I should have tried Android before wiping out the boot entries with efibootmgr.

                  • 6. Re: Attempting to dual boot ubuntu
                    linuxium

                    So now you have removed the boot entries with 'efibootmgr' I suggest re-installing Ubuntu from the LiveUSB (select 're-install Ubuntu' rather than 'upgrade' or 'erase disk and install Ubuntu' which given the option in the installater). And before doing so make sure BIOS is set at 64-bit. With a clean install of Ubuntu the GRUB menu should be the first thing you see when booting and this will have options to boot either Ubuntu or Windows.

                    • 7. Re: Attempting to dual boot ubuntu
                      Repeat%20Offender

                      I tried reinstalling ubuntu. Then I did the update and upgrade, then shut down the Stick, removed the USB drive and held the power button for 3 seconds (trying to access BIOS during a normal boot never works for me; I always have to hold the power button for 3 seconds), hit <F2>, chose Windows 32-bit, with the result "A bootable device has not been detected"

                      Power off, then tried <F10>. The only choice was UEFI : ubuntu : PART 1 : OS Bootloader. After choosing it got into the GRUB menu and booted into ubuntu.

                      Shut down and tried normal boot. Again arrived at GRUB. At this point choosing Windows Boot Manager (on /dev/mmcblk0p2) simply cycles back to the GRUB menu, so I booted to ubuntu.

                      Shut down, the tried <F2> and chose Windows 32-bit, which brought me back to GRUB again. Windows &c still cycles, so I booted to ubuntu.

                      Shut down and tried <F10>. Again, the only choice was UEFI : ubuntu : PART 1 : OS Bootloader and again arrived at GRUB. Windows &c cycles so I booted to ubuntu.

                      Shut down and performed a normal boot. Got to GRUB. Windows &c cycles, so I booted to ubuntu.

                      Shut down and tried <F2> and chose Android, this time I got A bootable device has not been detected.

                      Power off, then tried <F10>. The only choice was UEFI : ubuntu : PART 1 : OS Bootloader and again arrived at GRUB. Windows &c cycles so I booted to ubuntu.

                      Shut down and performed a normal boot and was back at the GRUB menu...

                       

                      So now I can boot to ubuntu, even most of the time, but not Windows.

                      • 8. Re: Attempting to dual boot ubuntu
                        linuxium

                        I'm not sure why you first changed the BIOS back to Windows 32-bit after installing Ubuntu. Because you only need to choose the 64-bit bootloader in the BIOS at the beginning and then install Windows followed by Ubuntu. After that when you power-on you will get the GRUB menu from which you can chose to boot either Windows or Ubuntu.

                         

                        At this point it is probably faster to start again rather than diagnose and try to fix your current install. I recommend you just install the two operating systems and confirm dual-booting works and then fix issues like missing drivers and performing updates and upgrades. Start by removing all USBs, SD cards etc and boot the stick into the BIOS and make sure the bootloader is set as 64-bit. Then insert your 'Windows 10 x64' bootable USB and install Windows (deleting all partitions when prompted to do so). During the installation process do not connect to the internet (either wirelessly or using a USB ethernet), use a local account for the install and do not attempt to perform any updates. Once Windows has installed remove the USB and confirm that you can boot in and out of Windows. Then boot into Windows again and reduce the size of the C: drive by 10GB to create space for the Ubuntu install. Next insert your 'Zesty ISO' bootable USB and install Ubuntu using the 'Install Ubuntu alongside Windows Boot Manager' option during the installation. Again during the installation process do not connect to the internet (either wirelessly or using a USB ethernet) and do not attempt to perform any updates or upgrades.  Once Ubuntu has installed remove the USB and confirm that you can boot in and out of Ubuntu using the GRUB menu. Then confirm that you can boot in and out of Windows using the GRUB menu. Having successfully installed and dual-booted Windows and Ubuntu your Windows install will be missing key drivers like audio and both will need updates to be applied. Connecting to the internet is now okay to do. To 'fix' Windows it is best to download and use the 'Intel Driver Update Utility' from Intel's website and Ubuntu can be updated using 'sudo apt-get update && sudo apt-get upgrade' as usual. You can see further instructions how to do this in the video. After that everything should work.

                        1 of 1 people found this helpful
                        • 9. Re: Attempting to dual boot ubuntu
                          Repeat%20Offender

                          Well, I can sort of dual boot at this time. If I'm in ubuntu I can boot to Windows via

                           

                          sudo efibootmgr -o 0002,0000

                           

                          And then setting the BIOS to boot to 64-bit Windows. Unfortunately

                           

                          sudo efibootmgr -n 2

                           

                          Didn't do the trick. To get back to ubuntu, I boot from the Live USB and enter

                           

                          sudo efibootmgr -o 0000,0002

                           

                          Then shutdown, remove the Live USB, and reboot. The BIOS seems to get switched to 32-bit Windows at some point along the way. Gary Newell's pages, for example How To Change The EFI Boot Order With efibootmgr  and How To Remove Ubuntu From A Computer Dual Booting With Windows 10 (UEFI only) « Everyday Linux User were very useful for figuring this out.

                           

                          This may be a bug in the BIOS in that in either case I only see one boot entry: either

                           

                          UEFI : Ubuntu : PART 1 : OS Bootloader

                           

                          or

                           

                          UEFI : Windows Boot Manager : PART 1 : OS Bootloader

                           

                          Both in the <F2> screen and the <F10> screen. Or do you think it could have been operator error in that I might have installed one OS in EFI mode and the other in legacy mode? But if I did that, would both boot entries be prefaced by UEFI? How could I make sure, for each OS, that I was installing in EFI mode?

                           

                          I may yet reinstall all that jazz once again, but I would like no know whether this is a BIOS bug or not first and I have at least marginal functionality for now.

                          • 10. Re: Attempting to dual boot ubuntu
                            linuxium

                            The Intel Compute Stick only seems to show one UEFI boot option from the NVRAM. This shouldn't matter though because as long as you set it to the Ubuntu one, that should boot GRUB from where you can then choose either Ubuntu or Windows. However you have said that this doesn't work when trying to boot Windows. Given that Windows is installed and bootable I would boot your installed Ubuntu and then enter 'sudo update-grub' to re-create your GRUB menu. Then reboot and see if booting the Windows option from GRUB works. Also given that your EFI partition seems okay, have you tried using the built-in EFI shell? First you have to (may have to) enable it from the F2 BIOS boot menu and then you can select 'UEFI: Build-in EFI Shell' option as the F10 boot device. There are plenty of guides out there on the web but it will be along the lines of entering 'fs0:' to start and then 'ls' to see the directory structure with 'cd' to change and finally running the various 'grubx64.efi/shimx64.efi' typically in \EFI\ubuntu\ or \EFI\BOOT\ for Ubuntu and 'bootmgfw.efi' etc in \EFI\Microsoft\Boot\ for Windows.

                            1 of 1 people found this helpful
                            • 11. Re: Attempting to dual boot ubuntu
                              Repeat%20Offender

                              I had some time to try playing around with linux again today. sudo update-grub didn't help: choosing the Windows boot manager entry still just cycles back to the GRUB menu.

                               

                              I was able to get to the EFI shell as you described, but doing anything constructive from there is beyond my capabilities at this point. I found a little tutorial EFI Shells and Scripting | Intel® Software  but it didn't help that much because some commands such as bcfg didn't seem to be available on the STK1AW32SC, not to mention that the results of any command would scroll off the screen and there is nothing like mode to get a bigger effective terminal or more to stop the scrolling.

                               

                              So that was kind of a bust, but I more clearly worked out the sequence I need to dual boot currently:

                               

                              From Windows, with the power off, insert the Live USB

                              Turn the power on

                              From the <F10> menu select boot to USB

                              At the GRUB menu select try Ubuntu without installing

                              After ubuntu boots, hit <CTRL>-<ALT>-T to start the terminal, then enter the commands

                              sudo efibootmgr -o 0003,0000,0002

                              sudo poweroff

                              The first command assumed 0003 was the USB, 0000 was ubuntu, and 0002 was Windows. The second command was necessary because ubuntu boots into the wrong video mode and the icon you need to shut down is not visible.

                              Then remove the USB

                              Turn the power on

                              From the <F2> menu select Windows 32-bit

                              Now the Stick boots to ubuntu.

                               

                              From ubuntu,

                              Turn the power on

                              Choose ubuntu from the GRUB menu

                              Log in to ubuntu, then hit <CTRL>-<ALT>-T to start the terminal, then enter the commands

                              sudo efibootmgr -o 0002,0000

                              sudo poweroff

                              Turn the power on

                              From the <F2> menu select Windows 64-bit

                              Now the Compute Stick boots to Windows.

                               

                              Kind of an ugly sequence; it would be nice if one of the menus in BIOS or GRUB worked, but that's nonsupported software for you I guess.

                              • 12. Re: Attempting to dual boot ubuntu
                                linuxium

                                This has clarified what the problem is: your installed Ubuntu is using 32-bit GRUB rather than 64-bit GRUB. That is easy to fix as you just need to install 64-bit GRUB when running your installed Ubuntu i.e. not the one on USB. In a terminal enter 'sudo apt-get install grub2-common grub-efi-amd64-signed grub-efi-amd64-bin grub-efi-amd64 shim shim-signed' and then (just to be sure) enter 'sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --boot-directory=/boot --bootloader-id=ubuntu' and then reboot, F2 to swap BIOS back to 64-bit, and then boot to GRUB where both Windows and Ubuntu should work. 

                                1 of 1 people found this helpful
                                • 13. Re: Attempting to dual boot ubuntu
                                  Repeat%20Offender

                                  Nice haruspicy and incantation! Indeed GRUB works appropriately now. There would be no chance for users such as myself to get ubuntu up and running on the STK1AW32SC without your efforts. Sound and WiFi are not problematic. Which microSD card should I get to replace my 64 GB SanDisk card that ubuntu can't see?

                                  • 14. Re: Attempting to dual boot ubuntu
                                    linuxium

                                    Here's a post I did about micro SD cards a while ago: linuxium.com.au: Performance testing microSD cards ... I'm currently using my 32GB Samsung PRO cards with Ubuntu on the STK1AW32SC as my Sandisks cards do not work.

                                    1 2 Previous Next