3 Replies Latest reply on Jan 3, 2017 5:30 PM by Intel Corporation

    Can't get the recommended driver?

    Shane25

      I installed Battlefield 1 and when I run it, it displays an error. It says Detected Intel driver version 20.19.15.4483. The recommended driver version is xx.xx.xx.4539 or later. Please update your drivers at http://downloadcenter.intel.com/ before playing the game. I have tried downloading the recommended driver version however, it says it is unable to update with my computer.

       

      I have an Alienware Aurora R5

      The specs are:

      Intel Core i5-6400 CPU @ 2.70GHz

      8.00 GB

      amd radeon rx 480