1 2 Previous Next 20 Replies Latest reply on Feb 2, 2017 10:51 AM by Intel Corporation

    I can't update Intel HD 4600 drivers to Newer than 10.18.14.4414 - Need Urgent HELP!

    UmrenTV

      I have recently bought a Miracast device for my TV and I want to stream some content from PC to TV.

      In order to connect to with WiDi and Install the WiDi Drivers, I've read that I need Newer Driver for Intel HD Graphics.

       

      I am running Windows 7 Ultimate, I have i7 4790K, I have currently GTX 1080 running as main graphic hooked up to 2 monitors, and Intel HD 4600 as (disabled so far) secondary.
      I enabled that yesterday from the BIOS as IGD and there was option in BIOS to select what memory it shares... I selected 512MB - it was max option. (I don't know if all of this is relevant but I want to give u some info)

       

      Now these are my concerns.
      From my previous experience of 3-4 Laptops and PC's owned... usually when I right click on Desktop I have "Graphic Properties" that is coming from Intel in the menu. Now I don't. No idea why.
      When I open Nvidia Control Panel.. and go over to Global Settings... I usually have "Prefered Graphic Processor" or something. Now I don't.

      I tried EVERYTHING to update the driver.. with the newest win64_153631.4414, older win64_153628.4332 drivers.. and it won't upgrade from 10.18.14.4414 no matter what I do.


      This is what I tried so far:
      1. I have tried "Upgrade Driver" from the Device manager, extracted the Zip, pointed "Have Disk" location... and it's saying "Your Drivers are Up to Date" while clearly they are not.

      2. I have made Clean Boot with everything except windows services running, Uninstalled the drivers + Software completely, restarted. I got the Message "Sorry Windows couldn't install this device - No driver Found". I right clicked in Device Manager, found the drivers, installed them .. and I still got 10.18.14.4414 version even tho the zip downloaded, contains the Newest Drivers only. Tried with Newest and with Older. Still same.

      3. I went to System32... gave myself Owner Permissions... deleted from Driver Repository the IGN folders... uninstalled again together with software... restarted to Clean Boot... reinstalled again.. no luck.

      4. I downloaded the Intel Driver Update utility. It shows that I have installed Version "10.18.14.4414" and that Newest is 153631.4414 ... I press Download / Install.. it won't change them, even after screen blinking, restart done, etc.

       

      I've spent over 20 hours troubleshooting before I ask help from you... but I am kinda desperate.. I don't want 70Euros to go down the drain because I can't install drivers for the HD 4600.

       

      Another quick question:

      In order to install the Widi what other drivers I need to check for updating? Intel Chipset, Intel HD Graphics, ... ?

       

      Since I am doing YouTube / Live Streaming for Living, and this is quite urgent matter for me, to make everything functional, I appreciate all of your help.

      Thank you Very Very Much, for your support, in advance.

       

      P.S. Sorry for any English errors in my text, It's not my mother language

      Intel Widi.png

        1 2 Previous Next