4 Replies Latest reply on Jan 16, 2017 6:39 AM by Intel Corporation

    NUC 5i3 Not posting or booting or anything

    chestwood96

      Something wired just happened, I think my NUC is dead .

       

      After my "Media-Setup"(wich is just a TV with a passively cooled NUC strapped to it) was unplugged and not Touched for a While(several Months) I wanted to start it again but nothing happened and I mean NOTHING no beeps no lights(power and network) no picture nothing.

      Nothing was changed and it was not touched in Months. It was running fine 24/7 wit >70C temps for Months before it was shut down.

       

      So I did the usual, resocket the RAM(tried the ram in a laptop and it worked fine), unplugged the ssd and checked the PSU but still nothing happened.

      Then I removed the board and just plugged that in, then I at least saw the green power LED but still nothing happened when Ipressed the button.

      Then I checked the button but that seems to be working acording to my Multimeter.

       

      I then saw that if I press the Button for a long time (>20sec) sometimes the blue led would flash for a short time (>1sec) and sometimes the orange one too but it dod not correspond to any of the blinking paterns for the NUC.

       

      I also tried different combinations of removing the BIOS battery and the jumper but to no avail.

       

      This really sucks because I was looking forward to using my TV again after the whole Renovation thing and I also do not know if I can RMA it because of the Passively cooled case.

       

      So does anybody know how I can fix it or if I can RMA it?

       

      Also of I can RMA it do I send it to the Seller or to Intel directly and do I have to put it in the original case?