4 Replies Latest reply on Feb 15, 2010 10:43 AM by Ozz

    Windows XP and AHCI - X25-M/V user feedback on older versions of Windows

    Ozz

      Thinking of setting up an X25-V but it will have to be on an XP (32bit) system. It's an Intel machine, with an ICH10R southbridge, so AHCI is an option (currently in IDE compatibility mode).

       

      I've always been of the understanding that AHCI mode under XP isn't very good performance wise (essentially XP = IDE mode, Vista and later = AHCI). With SSDs, I'm guessing this is different, and that AHCI mode under XP is much preferred.

       

      Can anyone who is using XP as a platform and an Intel SSD provide some feedback? Are there any problems to expect? (apart from the need of floppy drivers when installing XP with AHCI mode!)

       

      Thanks!

       

      PS. just remembered an important one from previous reading: partition alignment - is the easiest method to just install/piggyback the SSD into an existing Windows 7 or Vista computer, and simply create the partition via disk management? Then just remove and install XP as per normal?

        • 1. Re: Windows XP and AHCI - X25-M/V user feedback on older versions of Windows
          ZXTT95

          The only issue I'm familiar with regarding XP is the problem of installing to AHCI from an XP boot CD, which may not have the drivers.  The normal solutions are to supply the drivers from a floppy using F6 or slipstream them onto a new XP CD you burn yourself.

           

          There's an even easier way - boot from the Vista or Win7 install DVD and partition the drive from the drive selection menu, but don't bother installing.

          • 2. Re: Windows XP and AHCI - X25-M/V user feedback on older versions of Windows
            Ozz

            I have access to a floppy drive so that should be no problem. I could slipstream the drivers with something like nlite, but it'd probably just as easy to crank out ol' faithful..

             

            After some reading, i see what you mean, that you can back out of a 7/vista install after creating the partition.. I see one small issue with doing this with a win7 disc (as I'm planning, or could possibly get my hands on a vista one) - that is, win7 RTM seems to create an additional partition no matter what - i don't know if you can delete this or not... may mess up things.

             

             

            With these complications, I'm wondering if it simply might be easier/more guaranteed to just piggy back the X25-V it to my current win7 install; that way i can  run the SSD Toolbox and run a full diagnostic before drive commission, then partition it.

            • 3. Re: Windows XP and AHCI - X25-M/V user feedback on older versions of Windows
              ZXTT95

              If you don't mind hooking it up to another machine, go ahead.

               

              If anyone is interested, there are a couple of workarounds to the Win7 100 MB partitition:

              1. Delete the 100 MB partition and extend the other partition to include its space.

              2. Instead of using the GUI, type SHIFT-F10 for a command prompt and use diskpart.

               

              Search for windows 7 100mb partition and you should be able to find details.

              • 4. Re: Windows XP and AHCI - X25-M/V user feedback on older versions of Windows
                Ozz

                Thanks for your feedback, ZXTT95