6 Replies Latest reply on Dec 12, 2016 2:09 PM by thepianoman

    USB 2.0 Headers Not Working - ASRock Z97 Fatal1ty Killer

    thepianoman

      System Specs:

       

      MB: ASRock Fatal1ty Z97 Killer

      CPU: Intel i7 4790K

      GPU: MSI Geforce GTX 960

      RAM: 16gb Gskill DDR3 1866

      SSD x 2

      750W power supply

      DVD optical drive

      Card reader

       

      USB 2.0 headers on my Mobo are no longer working (two total). I recently installed an Intel AC-7260 wireless card with bluetooth (requires header for bluetooth functionality), worked fine. Installed a card reader (required a header as well, in addition to the ports on the front- so I bought the NZXT IU01 USB expansion, worked like a charm). I noticed BT no longer working. USB Card Reader no longer working. Seems to have power, my portable HDD indicator light flashes briefly when plugged in and is spinning.

       

      Summary:

       

      - USB 2.0 headers not working.

      - USB 2.0 ports on the rear work fine.

      - USB 3.0 ports all work fine.

      - Tried both devices on both headers, nothing.

      - Tried updating and rolling back intel chipset drivers, nothing.

       

      I'm baffled as to what I should do next. I'm no computer genius, but I know my way around my computer. Numerous searches reveal nothing useful. I tried to retrace my steps, and the only thing I can think is I had to rearrange the power connections inside my case so everything would reach when I installed the DVD drive, but the USB 2.0 headers are powered by the main MB 24 pin power connector, correct? Anything I am missing here? I assume it's a driver issue (as there is power to the headers)?