1 2 Previous Next 17 Replies Latest reply on Dec 12, 2016 7:11 AM by Intel Corporation

    NUC6i7KYK Not Booting if USB3.0 Connected

    Nagisan

      Having a problem with this thing, I have a SATA enclosure that holds multiple disk drives running over USB 3.0, if I have it connected when I boot the system it gets stuck at the Intel NUC screen and will eventually change to some error text (along the lines of "We detected the device did not boot properly, type 'Y' and hit enter to enter setup or 'N' to continue"). At this point the system is frozen and I cannot continue or enter setup, I have to power the system down and try again.

       

      If I remove the SATA enclosure the system boots properly and I can reconnect it later with no issues.

       

      I also noticed if I remove the enclosure and boot into Setup then reconnect the enclosure (while in Setup) it will freeze, though it appears to resume normal operation if I then disconnect the enclosure again.

       

      Is there a known fix for this? I do not need the devices at boot but I do not want to have to reconnect them every time I attempt the reboot the system.

        • 1. Re: NUC6i7KYK Not Booting if USB3.0 Connected
          Lithorien

          Try disabling USB boot in the BIOS, perhaps? If you don't need the SATA enclosure for it, anyway.

          • 2. Re: NUC6i7KYK Not Booting if USB3.0 Connected
            Nagisan

            Just gave that a try, still no luck.

             

            Its a really interesting problem, USB Booting is no longer enabled (which I did use the feature to install Windows) but it still locks up when the SATA enclosure is connected.

             

            It definitely has to do with that device though, even after it is sitting at the Intel NUC screen, if I disconnect the device then reconnect it (without specifically waiting for it to continue) it will continue with the bootup process and get into Windows without an issue.

             

            I'm leery to disable USB on boot entirely in case I need to get into the BIOS later and forget how to re-enable USB (by holding the power button, from an unpowered state, until it beeps or whatever).

             

            I have also updated to the latest available BIOS version and have tried changing to a different USB port, I have not tried running through a USB 2.0 HUB as that's sort of a last resort because I occasionally transfer from one drive in the enclosure to another and don't want to speed drop of USB 2.0 vs 3.0.

            • 3. Re: NUC6i7KYK Not Booting if USB3.0 Connected
              N.Scott.Pearson

              One more thing to try: Enable Fast Boot and see if the same issue occurs. Fast Boot would still require power button menu to make subsequent changes, however...

              • 4. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                Nagisan

                Fast Boot did work, the only problem is Windows fails to properly detect the device when booting with Fast Boot enabled. I then have to unplug and plug the enclosure back in to get the drives to appear, leaving me in no better of a position (it at least powers on properly with Fast Boot but still requires the same overall effort to reboot the machine and access the drives).

                 

                I also tried plugging the device into a USB 2.0 HUB and it made no difference, it's like the system is completely ignoring the disabled "USB Boot" option and reading through the USB drives looking for a boot device or something (though this wouldn't explain why the system freezes in the BIOS when I simply plug in the enclosure, and starts working again if I unplug it afterwards).

                • 5. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                  N.Scott.Pearson

                  Hhmmm, when you boot using Fast Boot, the BIOS leave the initialization of the USB hardware for Windows to perform. If you have the Chipset Software package installed, Windows should have all it needs to fully initialize this hardware and enumerate all devices below it. There is something really odd going on here...

                   

                  Please provide more information regarding the enclosure used, the drive(s) included in it and how they are organized, formatted, etc.

                   

                  ...S

                  • 6. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                    Nagisan

                    The enclosure is: Vantec 4 Bays 3.5-Inch SATA to USB 3.0

                     

                    I'm not sure of the exact make/models of the drives in it but there is 1x 3TB, 1x 2TB and 2x 1TB, running in no special configuration (JBOD).

                     

                    I did explicitly install the chipset drivers from Intels product page for the NUC so I wouldn't think that would cause issues. It seems that maybe the enclosure is taking too long to ready the disks if it's not starting until after Windows activates the USB ports, causing Windows to attempt to mount the drives before they are ready...unfortunately I don't know enough about how Windows interacts with hardware to say whether or not that could be the case.

                     

                    That- wouldn't really explain why the NUC is locking up in the BIOS when the enclosure is connected either.

                    • 7. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                      DougM53

                      I can't help with a solution, but I don't think there is one.

                      I have this issue with four computers when I try to start them with multiple large discs connected to usb.

                      It has been on Win7, 8.1 and 10.

                       

                      So it isn't a NUC only issue. I suspect it is a windows issue. On mine the windows wheel of dots is there so it is trying to boot from the drive with the o/s on it.

                      I can only suggest it is the system reading the discs before finishing the boot sequence and can't complete the task.

                      Left long enough the computers just turn off, so possibly windows can't handle this much work on start up.

                       

                      My solution was same as yours, disconnect or turn off  the drives. Much faster and unless your drives or ports  are hard to get at it seems a simple work around. One pc of mine is in a cabinet and hard to get to, but I just made it so I could get to the drives or their power supplies easily.

                       

                      For a possible solution I suggest operating system forums.

                      • 8. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                        Nagisan

                        I severely doubt it is the OS. Earlier this week I had the same enclosure (drives included) on a Win7 system that had been running for ~2 years and it NEVER had bootup issues. Also, the freeze happens ONLY during BIOS operations, if I let the system boot past the BIOS stuff (plug it in a few seconds after the "F2 to enter SETUP" text and what not appears), it goes on to start loading Windows and doesn't have an issue with it (and USUALLY boots with the drives accessible by the time I log into Windows.....not the case due to the issue I mentioned a few posts back when turning on Fast Boot, which disables BIOS USB).

                         

                        The issue I'm having primarily is the Intel NUC itself is unable to POST with this SATA to USB Enclosure connected, disconnect it and it POSTs fine. An extension of the issue is configuring the BIOS settings will freeze if I connect the enclosure during setup, and become responsive again if I disconnect it.....its like plugging in the enclosure halts the system somehow (it's not just the mouse/keyboard that freezes, the actual animated stuff in the BIOS will stop mid-animation, to continue again when removing the enclosure). It's also not a video output freeze, no input is accepted while its frozen (in fact the keyboard even refuses to toggle numlock, for example, while it's frozen, working normally when the enclosure is removed).

                         

                        To put it as short as I can, the issue only every happens during system bootup before the OS starts....as soon as the system POSTs I can connect the drives and the OS will start and finish loading with no issue.

                        • 9. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                          Intel Corporation
                          This message was posted on behalf of Intel Corporation

                          Please confirm the BIOS version 0042 is currently running on your NUC.
                          Does this issue happen with different USB enclosures? 
                          Does this problem occur with only USB enclosure or regular USB 3.0 flash drives?

                          Allan

                           

                          • 10. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                            Nagisan

                            The BIOS is indeed 0042, unfortunately I do not have a different USB enclosure to try out and I don't want to have to buy one that works fine on other systems. I did however try my USB 3.0 flash drive (a 64GB one) and it has no problems POSTing and booting into Windows with it connected.

                            • 11. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                              N.Scott.Pearson

                              Hhmmm, I vaguely (old f@rt ) remember there being an issue a few years back, where the presence of a large USB drive (at that time, if I am remembering correctly, it was a 5TB drive) caused a board's BIOS to hang. This sounds suspiciously like that same problem. A search located the original reports (note plural; turns out it happened a couple of different times with different BIOSs ).

                               

                              One observation in these reports got me thinking. If you have a drive that is bigger than 3TB, UEFI is needed to support it. What if the BIOS was inadvertently enabling UEFI, even though not enabled, and this is causing the hang (i.e. UEFI boot attempt with Legacy image). So, the question becomes: Are you enabling UEFI and booting a UEFI image? If not, I wonder, if you were using a UEFI image, would this make the problem go away? This is just a theory; I don't have the hardware to test it, however.

                               

                              ...S

                              • 12. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                                Nagisan

                                Alright, I double-checked the BIOS and it is running with UEFI enabled, I am unsure if whether or not Windows is actually using it (not sure how to check, UEFI was enabled during installation though) but again, the issue happens only before Windows loads.

                                 

                                Could having UEFI enabled be the cause of the problem with the BIOS? I tried multiple things a few days ago, disabling UEFI was one of them, but it only seemed to cause more issues (couldn't find the boot device) until I re-enabled it.

                                 

                                One thing that may have made a difference though, I did install Windows without the USB enclosure connected, connecting it only after I had Windows installed and configured. I doubt that would cause an issue as it happens before the BIOS starts loading Windows but I have no idea how UEFI works so I'm open to all possibilities.

                                • 13. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                                  N.Scott.Pearson

                                  You can usually tell if the O/S is booting in UEFI mode by looking in BIOS Setup (Visual BIOS) at the boot order. If the drive has an entry in the UEFI boot order, it was installed to boot in UEFI mode. As well, if disabling UEFI stops it from booting, this is a pretty good indicator itself.

                                   

                                  My recommendation is to install the O/S with only the system device installed. All other storage devices should be hooked up (only) afterwards.

                                   

                                  ...S

                                  • 14. Re: NUC6i7KYK Not Booting if USB3.0 Connected
                                    Nagisan

                                    Sorry if I was unclear with my previous post, the OS was installed with ONLY the system drive (250GB M.2 SSD) connected, I didn't connect any other storage devices until after the OS was up and running, that's when I discovered the boot issue with the USB enclosure connected.

                                    1 2 Previous Next