6 Replies Latest reply on Nov 29, 2016 11:53 AM by Intel Corporation

    DH67CL died after setting faster memory timings

    paramountain

      This involves a i5-2500K / DH67CL. I thought I'd take advantage of the faster timing of the Crucial memory (7-7-7-24). Big mistake. I went into BIOS and changed the memory mode from Automatic to Manual, as the DH67CL does not recognize native timing, and changed the top four numbers to 7-7-7-24. I saved and booted, only to discover that the system was toast. I disconnected the SSD and HDD. I swapped various sticks, all either Crucial or Hynix, brands with which I've had 100% success. I removed the battery for a few hours. Nothing changes the symptoms, which are:

       

      When I press the power button, the system starts (fans turn, front power LED lighted, and DVD-CD light flashes) for a second or two and then stops. It will do that for a few cycles, but I don't know if it will continue forever because I won't let it. If I press and hold the button, it will beep three times; if I hold the button down after the cycle starts, it will beep a subset of that depending upon what part of the cycle I hit. Nothing ever shows on the monitor. The monitor LED never changes from yellow to blue, as it always does when it starts receiving a digital signal. The monitor, keyboard, mouse, and cables work with other systems (I'm using them right now). Adding a video card or different PSU changes nothing.

       

      I think the board is confused because of the memory timing changes, not to mention the three beeps. I do not understand why removing the battery does not reset all defaults, but I think I found another obscure bug which will never be fixed. The BIOS is already at 0160, the latest.

       

      UPDATE: I let it sit sans battery all night. This morning I downloaded BIOS 0159. I was going to use my old external floppy drive until I realized that the almost 10 MB file would not fit. I copied it to a USB flash drive and inserted it into a back panel port. I removed the jumper and powered the PC up. No video was seen, but the fans ran and the power light on the front was lighted. I let it run that way for 1/2 hour. I think it would have run forever, so I pressed and held the power switch to turn it off. I removed the USB flash drive and reinserted the jumper. The symptoms are the same as before.

       

      Is there a super-duper method of bringing a board back to factory defaults?

        • 1. Re: DH67CL died after setting faster memory timings
          N.Scott.Pearson

          Yes, big mistake; there's a chance that you may have burned out the processor's memory controller(s). Let's hope not...

           

          First of all, let's talk about CMOS. In the dim past, BIOSs used to use the CMOS memory for the storage of its configuration parameters. With the advent of flash memory and its use for firmware storage (code and data - and yes, BIOS is firmware), BIOS vendors completely did away with the use of CMOS memory (but the CMOS devices stayed around to provide the battery-backed date and time). Unfortunately, it appears (at least in the case of AMI BIOS) that, despite the intervening years, references to CMOS memory have not been completely purged from the BIOS code. This is why clearing CMOS can make a difference in some cases (though it also appears that clearing just the date and time fixes some issues too). Yea, these are bugs - and yea, you would think that, after all this time, the bugs would have been found and fixed, but sadly, this isn't the case.

           

          Bottom line? Clearing CMOS will fix some issues, but it certainly doesn't reset the BIOS configuration to (factory) defaults. For this board, the only way to reset the BIOS configuration to (factory) defaults is to get into BIOS Setup and use F9 to do so. If you cannot get into BIOS Setup, you are in trouble.

           

          Ok, what to try next? Try to get into BIOS Setup via Maintenance Mode. To do this, do the following:

           

          1. Power off the system.
          2. Move the yellow jumper from BIOS configuration header pins 1-2 to pins 2-3.
          3. Power on the system.

           

          This should take you into BIOS Setup in Maintenance Mode. If you make it there, immediately use F9 to reset the BIOS configuration to defaults and exit BIOS Setup saving the new configuration.

           

          Power off to restore the jumper to pins 1-2.

           

           

          If that didn't work, the only thing that has a chance is to do a BIOS update via the Recovery Method. You said you tried this. There are some special things you need to do to ensure the best chance of this being successful:

           

          1. Format a USB 2.0 flash disk using the FAT32 file system. Do so even if you believe that it has been done before. Do not use USB 3.0 flash sticks. It *must* be formatted using the FAT32 file system and not any clones (specifically, never use the Linux ExFAT file system).
          2. Put the .BIO file onto the USB flash disk - and nothing else.
          3. Completely power off the system.
          4. Plug the USB flash disk into a (black) USB 2.0 port on the back panel of the board. Do not use (blue) USB 3.0 ports, do not use (yellow) USB charging ports and, especially, do not use front panel USB ports or ports on any kind of USB hub.
          5. Remove the yellow jumper from the BIOS Configuration header.
          6. Power on the system.
          7. The Recovery process should complete on its own. If you don't see its progress being displayed on the primary monitor, it likely isn't working - but, in this case, do not power off the system for at least 15 minutes (just in case it is working without displaying).
          8. When the Recovery process completes, you will be told so onscreen. Power off if this is the case.
          9. Restore the jumper to the 1-2 pins of the BIOS Configuration header.
          10. Power on.
          11. If you get to the splash screen, use F2 to enter BIOS setup and then use F9 to restore the configuration to factory defaults. Exit BIOS Setup with a save of the current configuration (the factory defaults).

           

          Let me know how it goes...

          ...S

          • 2. Re: DH67CL died after setting faster memory timings
            paramountain

            I'm still working through everything you wrote, but THANKS!

             

            Maintenance Mode, who knew? It even tells you to power-down the system and revert the jumper.

             

            I was able to boot the system normally, though it took longer (maybe twice as long as before, so maybe something was damaged) to reach the Intel splash screen. I logged on and saw that the Ethernet controller was inoperative, making me think I burned it. I uninstalled the driver and then reinstalled the latest one -- now Ethernet is back. Time and date were set to something like 1/1/2010, so I fixed that. I ran IPDT and saw no errors, so I guess I lucked out with respect to trashing the memory controller -- or maybe IPDT only tests on a gross level.

             

            BIOS is 0160, so my attempt to change it did not succeed. USB 3.0 flash drives are a problem? That's good to know.

             

            I'm not done with troubleshooting, but I want to fully digest what you wrote and test the PC more. I love to read your posts because you give all the nitty-gritty details that only insiders know. I'll post again tomorrow.

             

            UPDATE: I went back and checked Device Manager to see if there were any errors. You previously told me that ME was not necessary for my application, so I uninstalled it months ago. Now, Device Manager is not indicating the "PCI Simple ..." error that it did before. That's strange.

            • 3. Re: DH67CL died after setting faster memory timings
              paramountain

              I used it again this morning and the time to reach the Intel splash screen remains longer. That might be connected to Ethernet functionality, because just as I saw yesterday, Ethernet connectivity failed (Device Manager indicates errors for both Ethernet and PCI Simple ...). I'm going to disable the board's Ethernet in BIOS and  install a Vista-era Intel PCI Ethernet card and use it for a while to see how it goes.

               

              And the board has different behavior when leaving BIOS. Before, if I edited something and saved, the system would just continue the boot. Now, the system powers-down for maybe ten seconds before booting -- like he's doing a BIOS update.

               

              But back to the original topic; perhaps you can explain something. Isn't the purpose of the of the BIOS screen I used to modify memory parameters? If I am not allowed to set the parameters to the exact timing of my sticks, then why does that screen even exist? I seem to remember that you do not own a DH67 board, so I should tell you that it only has two options, automatic and manual; XMP profiles are not implemented.

               

              Is IPDT an adequate test of the memory controller or is there a better one?

               

              UPDATE: I disabled Ethernet in BIOS and added the Intel PCI Ethernet card. But there was no connectivity with the new card. So I enabled the onboard Ethernet, uninstalled the driver, rebooted, installed the current driver, and rebooted, thinking that drivers would be downloaded for the Ethernet card as soon as connectivity was established. However, the card does not even appear in Device Manager.

               

              UPDATE: I thought the problem with Ethernet might be Windows, so I unplugged the drives and connected a drive with Linux installed (it was installed on an identical system), but there was no Ethernet connectivity.

               

              Every time I boot (or power-off / power-on, I'm not sure), I have to uninstall and reinstall the Intel Ethernet driver in Windows.

               

              I tried to revert the BIOS using Express BIOS 0159, but Windows informed me that it was unsuccessful. I will now try a Recovery BIOS.

               

              UPDATE: Recovery BIOS eliminated the long delay at boot. Ethernet now starts as it did before. I'd like to hear your technical explanation, but BIOS appeared to have been really messed up, but now it's okay. And the "PCI Simple ..." error in Device Manager is back as it was before.

              • 4. Re: DH67CL died after setting faster memory timings
                N.Scott.Pearson

                Before I ever install an O/S, I always test new memory thoroughly using MemTest86+. I downloaded the ISO image and set up a USB flash key that I can use regularly.

                 

                My personal opinion: Don't use the Express BIOS Update (EBU) executables. Use the iFlash or BIOS F7 method. If you truly want to be sure (or you are downgrading), use the BIOS Recovery process. The BIOS Recovery process will overwrite *all* firmware components, whereas the other methods only update those components that have changed. It also ensures that the Management Engine (ME) firmware is either refreshed or upgraded.

                 

                As I mentioned above, the only way to downgrade the BIOS is via the BIOS Recovery process. Note that downgrades are not recommended; the ME firmware cannot be downgraded (only upgraded) and it is possible to downgrade to a BIOS that is so much older that it is incompatible with the (much newer) ME firmware release(s). This could brick your board permanently. For a BIOS revision or two, this isn't an issue. If the BIOS revision number is significantly different, I wouldn't recommend downgrading to it. The release notes for the BIOS will usually indicate where the problem points are (i.e. places where, if you upgrade past it, you cannot downgrade back past it).

                 

                The PCI Simple Communications Controller is actually the hardware interface that allows software running on your main processor to communicate with the firmware running on the ME. This hardware interface is currently being referred to as the Management Engine Interface (MEI). It was originally called the Host-to-Embedded Controller Interface (HECI). There is a download package for every board that will install the driver for this interface (as well as any related software). With your particular board, you likely won't ever use any software that needs to communicate over MEI, so installing the driver is optional.

                 

                I don't like some of the software that comes in the MEI packages (a topic for a rant at some later date). But, at the same time, I don't like seeing unresolved entries in Device Manager. What I do is dig into the MEI package and manually install only the MEI driver via the INF method (if you don't understand what I just said, you likely shouldn't try this).

                 

                Hope this helps,

                ...S

                • 5. Re: DH67CL died after setting faster memory timings
                  paramountain

                  The sticks were not the problem. I have a myriad of ways to test RAM and my Crucial Tactical Ballistix 1333 7-7-7-24 earned a perfect score. I think there's a bug in BIOS in the screen allowing memory parameters to be changed.

                   

                  I chose the downgrade because 0160 was the latest available, so I couldn't upgrade. When I get around to it, I'll bring it back to 0160.

                   

                  Install ME via chipset functionality? I think only former Intel software engineers would even think of doing that.

                   

                  Thanks again for your assistance.

                  • 6. Re: DH67CL died after setting faster memory timings
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Great troubleshooting information from Scott. Thank you for your input.

                    Allan.