10 Replies Latest reply on Nov 30, 2016 12:43 PM by Intel Corporation

    NUC5i3RYH UEFI-only boot freeze

    andrei.ttr

      Hi,

       

      I got a NUC5i3RYH kit recently and I'm having issues setting up UEFI-only boot.Disabling "Legacy Boot" in the BIOS settings leaves me with no video (monitor reports no signal even after replugging several times), no keyboard (NumLock isn't responding) and the system hanging without booting anything or telling me what went wrong. The system is not responding to F-key presses or generating a keyboard beep either.

      I have to hold the power button to forcefully kill it. Rebooting solves nothing.

      The only way to get back into the BIOS is the power button menu (hold until beep).

      Enabling legacy boot alongside UEFI lets the system boot up normally again, but this isn't a solution for me as I require UEFI PXE booting (which for some ill-defined reason is completely forbidden if legacy boot fallback happens to be enabled).

       

      This is reproducible under BIOSes 0358 (factory version), 0359 and 0360. I tried restoring factory settings, updating / recovering the BIOS, clearing the bootorder efivars, nothing.

      Am I doing something wrong or is this unit defective?

        • 1. Re: NUC5i3RYH UEFI-only boot freeze
          MrMitch

          I tried this on my i3 RY with BIOS 0360 and it boots fine with Legacy disabled.  I have Windows 10 x64 UEFI installed.

           

          A few questions.

           

          1. Which OS are you using?

          2. Are you using an AHCI or NVMe SSD?

          3. When you did a BIOS recovery, did you use the Power Button menu or did you pull the Recovery jumper?

           

          First step I would do is enter the Visual BIOS and do an F9 Load Defaults. Then press F10 to save and exit. Sometimes this is all you need to do to clear some messed up settings and start fresh.

           

          Thanks.

          MRHunter9

          • 2. Re: NUC5i3RYH UEFI-only boot freeze
            andrei.ttr

            1. No OS, as I can't even get it to boot in UEFI-only mode.

            2. No SSD. One 2.5" HDD connected via SATA AHCI. I want to network boot anyway so it shouldn't matter.

            3. Power button. Didn't touch the recovery jumper.

             

            I can boot and run several Linux distros just fine from a USB stick in UEFI mode, assuming I leave legacy boot enabled, but that isn't an option.

            Loading BIOS defaults was one of the first things I tried before upgrading and reflashing the BIOS. Didn't help.

            • 3. Re: NUC5i3RYH UEFI-only boot freeze
              MrMitch

              Try doing a Jumper Recovery to BIOS 0360.  Put the RY0360.BIO file on a FAT32 formatted flash drive in the root with no other BIO file on the drive. unplug power, pull off the yellow recovery jumper that is next to the SoDIMM slots. Remove the HD as well just in case. So the only things plugged in is the USB keyboard, mouse and flash drive and monitor.

               

              When you power on, you should see a BIOS Flash message counting down to start the flash.  If you don't see this, but you do see the Recovery menu, you will need to try a different flash drive. USB flash drive support is kinda hit or miss for recovery. Usually an older USB 2.0 or 1.1 drive is best for some reason.

               

              When you see the countdown, just let it go and it should start the flash.  When it is done, shut off the NUC, pull the power cable and wait about 10 seconds. Put the yellow jumper back on the 1-2 pins on the board, plug the cable back in, and turn on the NUC but don't touch anything until it has booted through POST at least once.

               

              You should be good then.  Doing a Jumper Recovery reflashes the whole BIOS code + the ME.

               

              Hope that helps.

               

              MRHunter9

              • 4. Re: NUC5i3RYH UEFI-only boot freeze
                andrei.ttr

                I removed the HDD and did jumper BIOS recovery to 0360. Unfortunately this doesn't fix the problem.

                I tried it 3 separate times, following your exact instructions, with and without loading bios defaults before and/or after

                I also tried installing different RAM, still nothing.

                 

                In a moment of desperation I tried power cycling it over and over again with legacy boot disabled, spamming F10 on the keyboard. Just once I got it to present me a UEFI-only boot menu (the POST screen still did not appear) and I managed to get it network-booted into my existing UEFI PXE boot menu (*exactly* what I need). However, I think that was a fleeting fluke as I can't seem to make it happen again.

                • 5. Re: NUC5i3RYH UEFI-only boot freeze
                  andrei.ttr

                  UPDATE:

                  It seems that having the monitor connected during UEFI-only boot causes it to hang.

                  Disconnecting the monitor I get the keyboard LEDs light up, the machine network boots and I can even ssh into it! Connecting the monitor back after the OS has booted works fine also.

                  However, if I connect the monitor any time before the kernel loads (and, I assume, takes control of the hardware away from the UEFI firmware) the boot process hangs just as before. I'm using a display port monitor, by the way.

                  • 6. Re: NUC5i3RYH UEFI-only boot freeze
                    lw1948

                    Hello andrei.ttr

                    1. Try to change DP cable.

                    2. Or try to use HDMI connection.

                    • 7. Re: NUC5i3RYH UEFI-only boot freeze
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      Hello andrei.ttr,

                       

                      Connecting the monitor into the NUC before the booting process should not make any difference, so in this case try the suggestion mentioned above.

                       

                      Regards,

                      Amy.

                      • 8. Re: NUC5i3RYH UEFI-only boot freeze
                        Intel Corporation
                        This message was posted on behalf of Intel Corporation

                        andrei.ttr,

                         

                        Were you able to follow the suggestion mentioned above?

                         

                        Regards,

                        Amy.

                        • 9. Re: NUC5i3RYH UEFI-only boot freeze
                          andrei.ttr

                          Hi lw1948 intel_corp,

                           

                          I managed to get hold of a mini-DP multi adapter today and tried it with my NUC. UEFI-only booting seems to work fine now every time, I don't get hangs anymore.

                          I ran into some issues with resuming from suspend in Linux but found fixes for those quickly enough.

                           

                          It's still very odd how a straight-wired mini-DP -> DP cable caused the system to hang when legacy boot is disabled. Maybe it's an electrical issue, as neither the NUC nor the monitor have a grounded power supply adapter? I'm not sure at all.

                          • 10. Re: NUC5i3RYH UEFI-only boot freeze
                            Intel Corporation
                            This message was posted on behalf of Intel Corporation

                            Great news! 

                             

                            Well, it is an odd behavior. Normally, it should work with the connections that you had, as you mentioned that could have been a grounding issue.

                             

                            Regards,

                            Amy.