1 Reply Latest reply on Nov 15, 2016 1:10 PM by Intel Corporation

    Absurd bug with Windows Server 2008 SP2 causes the system to be completely unusable

    2008WindowsVista

      Hello everyone. I'm new to the forums here, so I apologize if this is the wrong place to post this. Please bear with me.

      Anyway, onto the issue I'm experiencing. I have installed Windows Server 2008 SP2 64-bit on one of my Haswell systems, with an ASUS H97M-E motherboard and a Core i5 4460.

      But the issue I'm experiencing is absolutely bizarre, and also seems to affect Windows Vista, as I tested that OS as well to ensure it wasn't exclusive to Server 2008, however I don't plan to use that OS as a main, since support is ending soon (Server 2008 support was recently extended until January 2020, along with Server 2008 R2 and Windows 7, so it's still a viable option). Other OSes I tested were Windows 7, 8.1, and 10 and they all worked normally, so this issue is exclusive to NT 6.0.

      Essentially, here's what happens. After installing Windows, the system will only boot successfully about every 5 out of 10 attempts. Each time it fails to boot successfully, the symptoms that occur vary. Here are the circumstances I've experienced:

      This is the most common occurrence. Just before when the login screen would normally appear, an error appears with the following text: "Interactive logon process initialization has failed. Please consult the event log for more details". Upon clicking Ok, usually the system will remain at a black screen, forcing me to hard reset.

      Another occurrence is as follows: the system will appear to boot normally, but after entering my password, it will logon to a blank screen. I then am forced to open Task Manager and start the explorer.exe process manually. After doing this, the desktop will appear, but lots of services have failed to start, such as Windows Audio, Windows Defender, etc, forcing me to once again hard reset until I can get the system to boot normally again.

      If the system boots normally and I want to restart the system, I can tell if this bug is going to activate again on the next boot attempt by checking for these symptoms: When the system begins to shut down, instead of the normal "Shutting down" screen appearing, the desktop will fade into a black screen with a cursor. The system will then shut down, and when this occurs, the system is guaranteed to fail on the next boot attempt, and I have to keep resetting until it boots properly.

      This bug is also not exclusive to my system, as I have several friends that own Haswell machines that are similar to mine, and I have requested that they try both Server 2008 and Vista, and they experience the exact same symptoms.

      When the system does boot normally, everything works as it should... so I'm absolutely stumped as to what to do. This is the most bizarre bug I have ever seen, especially considering that even Windows XP will at least boot properly on Haswell. But both Vista and Server 2008 just appear to be completely intolerant of Haswell. I know that Windows Vista is basically irrelevant these days and has never been exactly loved by many, but Windows Server 2008 will continue to be supported for another 4-5 years and has a much better reputation than Vista, so I feel that something really ought to be done to at least fix this issue for potential Server 2008 users that may need to use the OS on Haswell, whether for compatibility reasons or financial limitations. I am using it for the latter reason.

      Now, I know that driver support for the NT 6.0 family of operating systems is extremely limited on Haswell, but Intel did provide working chipset drivers, so I installed them. I also have a dedicated graphics card and don't use the onboard graphics, so that isn't an issue. The only missing drivers are the USB 3.0 drivers, but that shouldn't be contributing to this issue.

      If you ask me, it looks like Intel or Microsoft would have to be willing to release a hotfix to fix this problem, but considering that Server 2008 is out of mainstream support now, that's a bit of a stretch, unfortunately...

      Does anyone have any ideas on what else could be done to fix this issue? I've tried adjusting BIOS settings, installing all of the latest Windows Updates, etc... all the usual things. None of it helped at all with this issue.

       

      Thanks everyone.