3 Replies Latest reply on Nov 17, 2016 11:43 AM by Intel Corporation

    Intel Edison usb over ethernet interface not created on Ubuntu 16.04

    parthshah10391

      Hi! I am using an Intel Edison. When I connect the Edison to my desktop with Ubuntu 16.04 I do not see the interface being assigned an IP address. The Intel Edison does get an IP address i.e. 192.168.2.15 but my Ubuntu system does not get an output. Below is the output for both the devices.

       

      Intel Edison :-

       

      root@Edison:/home/multi_sensor# ifconfig

      lo        Link encap:Local Loopback 

                inet addr:127.0.0.1  Mask:255.0.0.0

                inet6 addr: ::1/128 Scope:Host

                UP LOOPBACK RUNNING  MTU:65536  Metric:1

                RX packets:0 errors:0 dropped:0 overruns:0 frame:0

                TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:0

                RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

       

       

      usb0      Link encap:Ethernet  HWaddr 02:00:86:c7:e9:83 

                inet addr:192.168.2.15  Bcast:192.168.2.255  Mask:255.255.255.0

                inet6 addr: fe80::86ff:fec7:e983/64 Scope:Link

                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

                RX packets:139 errors:0 dropped:0 overruns:0 frame:0

                TX packets:91 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:1000

                RX bytes:21426 (20.9 KiB)  TX bytes:24382 (23.8 KiB)

       

       

      wlan0     Link encap:Ethernet  HWaddr fc:db:b3:7e:61:f5 

                inet6 addr: fe80::fedb:b3ff:fe7e:61f5/64 Scope:Link

                UP BROADCAST MULTICAST  MTU:1500  Metric:1

                RX packets:0 errors:0 dropped:0 overruns:0 frame:0

                TX packets:43 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:1000

                RX bytes:0 (0.0 B)  TX bytes:8772 (8.5 KiB)

       

      Ubuntu 16.04 desktop :-

       

      eno1      Link encap:Ethernet  HWaddr 00:22:4d:54:b7:b4 

                inet addr:10.223.96.135  Bcast:10.223.96.255  Mask:255.255.255.0

                inet6 addr: fe80::4941:c99:3613:f640/64 Scope:Link

                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

                RX packets:68127 errors:0 dropped:0 overruns:0 frame:0

                TX packets:43329 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:1000

                RX bytes:56869936 (56.8 MB)  TX bytes:8963851 (8.9 MB)

                Interrupt:20 Memory:fe600000-fe620000

       

       

      enp0s26u1u1 Link encap:Ethernet  HWaddr d6:30:b1:1c:d3:ff 

                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

                RX packets:91 errors:0 dropped:0 overruns:0 frame:0

                TX packets:410 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:1000

                RX bytes:19104 (19.1 KB)  TX bytes:88798 (88.7 KB)

       

       

      lo        Link encap:Local Loopback 

                inet addr:127.0.0.1  Mask:255.0.0.0

                UP LOOPBACK RUNNING  MTU:65536  Metric:1

                RX packets:600 errors:0 dropped:0 overruns:0 frame:0

                TX packets:600 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:1

                RX bytes:54274 (54.2 KB)  TX bytes:54274 (54.2 KB)

       

      Can someone help me fix this?