7 Replies Latest reply on Jan 16, 2017 3:52 PM by Intel Corporation

    Mobile Device to Intel Edison Bluetooth

    NoahPena

      Hello,

       

      I am trying to transfer data from my Android device to the Intel Edison via Bluetooth using Bleno, but I am unable to pair the devices. The phone is able to see the correct name broadcasted from the edison, but whenever I try to pair the devices from Android, the edison accepts the connection and then immediately disconnects. Whenever this happens, the phone says that it is unable to pair due to an incorrect passkey or pin even though I was unable to type a passkey. I have tried connecting through bluetoothctl utility as well, but the device also disconnects almost immediately, but it does ask to confirm the pin.

       

      Versions:

       

      Bluez = 5.37

      Yocto = 201606061707

       

      What I've tried:

       

      Before I run the bluetoothctl utility I run:

       

      rfkill unblock bluetooth
      hciconfig hci0 up
      

       

      In the bluetoothctl utility i run the following:

      power on
      pairable on
      agent on
      default-agent
      discoverable on
      

       

      After those commands I am able to find the device from my phone.

       

      Using Bleno I run the following before:

       

      rfkill unblock bluetooth
      killall bluetoothd
      hciconfig hci0 up
      

       

      I run the "echo" example from the Bleno examples folder.

       

      I have tried reinstalling bluez5, but nothing changed.

       

      I have also tried the steps here: Setting up BlueZ with a passkey/PIN (to be used as headset for iPhone) , but to no avail.

       

      I have also tried installing ubilinux and trying these steps on there, but to even worse results.

       

      I am wondering if there is anything that I am missing to get the bluetooth working or if I should look to other bluetooth sources.

       

      Thank you!