5 Replies Latest reply on Nov 18, 2016 4:50 PM by Intel Corporation

    Installing Debian on Galileo Gen 2

    lonelyzerg

      Hi everyone,

       

      I am new to Galileo and I am trying to install Debian on Galileo Gen 2. I have a Ubuntu 16.04 computer and a Windows 10 pro computer. I tried to upgrade the firmware to 1.0.4 on Ubuntu but it report Target Firmware not Upgraded, and some java exceptions in terminal. When I reboot Galileo, the version of the firmware turns to be 1.0.4 so I just keep going. I use

      dd if=galileo-1.2.img of=/dev/sdb1
      

      to write the image to SD card. When rebooting the device, I got some mistakes and at last get into ramfs. I tried to press F7 when rebooting and exit grub, and went back to EFI firmware. There are 4 entries: UEFI payload, Intern Shell, Device List, and whatever, I can’t remember cause I do not have access to my linux pc now. I chose shell and it brings me back to grub, and I boot with 3.8.7 kernel and the same thing happened again and I went to ramfs.

       

      When I went back home and tried to do all these under Windows 10, I found that I cannot install drivers for Galileo, neither from linux-cdc-acm.cat downloaded from Intel, which reported “A problem was encountered while attempting to add the driver to the store.", nor from ardunio since I didn’t find any driver file or installation option for Galileo as it was said on the Internet.

       

      I hope someone could help me get these through. This is really annoying.

       

      Besides I can run arduino sketch normally through windows.

       

       

      EDIT: 11/9

      I get the driver installed by setting the date of my windows pc to one year ago (2015)