8 Replies Latest reply on Feb 10, 2010 9:59 PM by rajesh_shenoy

    DG33FB: Problem booting / BIOS corrupt

    rajesh_shenoy

      Recently I tried installing Windows 7 Ultimate and Ubuntu 9.10, and something seems to have gone wrong with the BIOS options in my DG33FB. The end result is that my system won't boot up normally. It loops endlessly in the reboot-Windows startup error cycle. The only way to boot is by going to BIOS Boot Options Menu (by pressing F10 on the Bios splash screen), and selecting my hard disk / DVD Drive from there.

       

      Also, in this Boot Options Menu screen, I see 16 (yes, SIXTEEN) instances of "Windows Boot Manager", followed by my drives! Selecting any instance of Windows Boot Manager only causes it to attempt booting and return to the same screen with one instance of WBM less (and so on till all 16 have been removed)!

       

      Some additional info: I have 1 SATA HDD, 1 IDE HDD and 1 IDE DVD Combo.

       

      I have tried all the following without success:

      1. Re-install OSes with re-partitioning / reformatting of both HDD's.

      2. Re-flash BIOS with same (latest) version and also previous version.

      3. Attempt install of 32-bit Windows 7. In this case, after first re-boot I get BSOD that BIOS is not fully ACPI compliant.

      4. Re-starting computer with all HDD and DVD drives removed. Even in this case, I see the 16 instances of Windows Boot Manager on pressing F10!

       

      Anyone has any other suggestion? Basically, I think I need to re-build the BIOS tables. Re-flashing the BIOS doesn't do this. Anyone knows any other way?

       

      Thanks in advance!

      - Rajesh