1 2 Previous Next 17 Replies Latest reply on Mar 27, 2017 6:08 AM by fager

    Program hangs after display driver update

    aarondemarre

      Category

      Questions

      Answers (N/A if not applicable)

      Description

      Provide a detailed description of the issue

      Application has hangs of 5-10 seconds long after updating the Intel HD Graphics drivers.

       

      The application contains a third-party CAD display that appears to have some sort of incompatibility with newer Intel graphics drivers. If the control is disabled, the issue goes away. However this control works without issue on older display drivers.

       

      If the drivers are rolled back, the issue goes away. If the drivers are uninstalled and the "Standard VGA" drivers are used, the issue goes away.

       

      This was tested on many separate Dell Latitude machines with different versions of Intel on board graphics and all exhibited the issues.

      Please place an X to the right of the option showing how often you see this issue using specific steps. (Ex: 'Every few times a game is started it flickers.' - This would be "Often")

      Always (100%): X

      Often (51-99%):

      Sporadic (20-50%):

      Very Sporadic (20%):

      Hardware (HW)

      Brand and Model of the system.

      Dell Latitude E5550 (Intel HD 5500)

      Dell Latitude E5570 (Intel HD 520)

      Hybrid or switchable graphics system?
      ie Does it have AMD or NV graphics too?

       

      Make and model of any Displays that are used to see the issue (see note2 below).
      LFP
      = Local Flat Panel (Laptop panel)
      EFP = External Flat Panel (Monitor you plug in)

      LFP

      How much memory [RAM] in the system (see note2 below).

      4GB

      Provide any other hardware needed to replicate the issue.
      ie: Cables&brand, cable type [vga, hdmi, DP, etc], dock, dongles/adapters, etc

       

      Hardware Stepping (see note1 below).

       

      Software (SW)

      Operating System version (see note2 below).

      Windows 7 Professional 64Bit

      VBIOS (video BIOS) version. This can be found in “information page” of CUI (right click on Desktop and select “Graphics Properties”.

      1039.18

      Graphics Driver version; for both integrated Intel and 3rd party vendors (see note2 below).

      10.18.15.4279 - Working driver

      20.19.15.4501 - Problem driver

      SW or Apps version used to replicate the issue.

      ThermDAC v8.4 (proprietary data acquisition software)

      Configurations

      Single display, clone, or extended (see note2 below).

      Single display

      Display resolution & refresh rate setting of each display (see note2 below).

      1366 x 769

      AC or DC mode, i.e. is power cable plugged in or not?

      DC, power cable plugged in

      How to repro

      Please provide steps to replicate the issue.  These steps are very crucial to finding the root cause and fix.
      A screenshot to illustrate the issue is a huge plus. A video of the failure is even better! Attach to the post or provide the YouTube link.

      1. Install driver 20.19.15.4501
      2. Open ThermDAC
      3. Manipulate CAD display
      4. App locks up for several seconds - see videos for good behavior (olddriver.mp4) vs bad behavior (newdriver.mp4)

       

       

      Explaination of the videos:

       

      In 'olddriver.mp4' this works an normal with no issues. I am able to rotate the CAD model without the app hanging. The mouse cursor is not visible, but I am clicking the rotate buttons and the drop down menus with no issues.

       

      In 'newdriver.mp4' I click the rotate button but nothing happens, finally the app goes grey and "not responding" shows up in the title bar. Eventually the app responds and all the click I did while the app was hung are processed as normal until the app hangs again seconds later.

        1 2 Previous Next