2 Replies Latest reply on Nov 3, 2016 7:32 PM by Intel Corporation

    Intel x520-T2 DCB problem

    n2o

      Hello.

      I cann't set dcb on mode from dcbtool in CentOs 7.

      lldpad daemon is running.

      Kernel is compiled with "CONFIG_DCB=y" flag.

       

      Some ethtool information.

      # ethtool -i enp1s0f0

      driver: ixgbe

      version: 4.4.6

      firmware-version: 0x80000389

      bus-info: 0000:01:00.0

      supports-statistics: yes

      supports-test: yes

      supports-eeprom-access: yes

      supports-register-dump: yes

      supports-priv-flags: yes

      # ethtool -k enp1s0f0

      Features for enp1s0f0:

      rx-checksumming: on

      tx-checksumming: on

          tx-checksum-ipv4: on

          tx-checksum-ip-generic: off [fixed]

          tx-checksum-ipv6: on

          tx-checksum-fcoe-crc: on [fixed]

          tx-checksum-sctp: on

      scatter-gather: on

          tx-scatter-gather: on

          tx-scatter-gather-fraglist: off [fixed]

      tcp-segmentation-offload: on

          tx-tcp-segmentation: on

          tx-tcp-ecn-segmentation: off [fixed]

          tx-tcp6-segmentation: on

      udp-fragmentation-offload: off [fixed]

      generic-segmentation-offload: on

      generic-receive-offload: on

      large-receive-offload: off

      rx-vlan-offload: on

      tx-vlan-offload: on

      ntuple-filters: off

      receive-hashing: on

      highdma: on [fixed]

      rx-vlan-filter: on [fixed]

      vlan-challenged: off [fixed]

      tx-lockless: off [fixed]

      netns-local: off [fixed]

      tx-gso-robust: off [fixed]

      tx-fcoe-segmentation: on [fixed]

      tx-gre-segmentation: off [fixed]

      tx-ipip-segmentation: off [fixed]

      tx-sit-segmentation: off [fixed]

      tx-udp_tnl-segmentation: off [fixed]

      tx-mpls-segmentation: off [fixed]

      fcoe-mtu: off [fixed]

      tx-nocache-copy: off

      loopback: off [fixed]

      rx-fcs: off [fixed]

      rx-all: off [fixed]

      tx-vlan-stag-hw-insert: off [fixed]

      rx-vlan-stag-hw-parse: off [fixed]

      rx-vlan-stag-filter: off [fixed]

      busy-poll: on [fixed]

       

      Some dcbtool information.

      # dcbtool sc enp1s0f0 dcb on

      Command:       Set Config

      Feature:       DCB State

      Port:          enp1s0f0

      Status:        Successful

      # dcbtool gc enp1s0f0 dcb

      Command:       Get Config

      Feature:       DCB State

      Port:          enp1s0f0

      Status:        Successful

      DCB State:    off

      # dcbtool go enp1s0f0 dcb

      Command:       Get Oper

      Feature:       DCB State

      Port:          enp1s0f0

      Status:        Command not applicable in IEEE-DCBX modes

       

      Some debug information from lldpad (running with -V 10).

      Adapter enp1s0f0 supports DCB.

      config.c: enp1s0f0 dcb mode is OFF.

      med_bld_tlv:enp1s0f0:LLDP-MED is not enabled

      med_gettlv:enp1s0f0: failed

      ieee8023_gettlv:enp1s0f0: failed

      send_msg: sendto = 44

      send_msg: sendto = 44

      send_msg: sendto = 36

      Adapter enp1s0f0 supports DCB.

      ERROR set_hw_state: set_linkmode dcbstate 1

      send_msg: sendto = 44

      mibConstrInfoLLDPDU: port enp1s0f0 mac 01:80:C2:00:00:0E type 0.

      mand_bld_ttl_tlv:enp1s0f0:done:type=3 length=2 ttl=120

      basman_bld_portdesc_tlv:enp1s0f0:Port Description disabled

      basman_bld_sysname_tlv:enp1s0f0:System Name disabled

      basman_bld_sysdesc_tlv:enp1s0f0:System Description disabled

      basman_bld_syscaps_tlv:enp1s0f0:System Capabilities disabled

      basman_bld_manaddr_tlv:enp1s0f0:Management Address disabled

      basman_gettlv:enp1s0f0: failed

      send_msg: sendto = 36

      Adapter enp1s0f0 supports DCB.

      config.c: enp1s0f0 dcb mode is OFF.

      med_bld_tlv:enp1s0f0:LLDP-MED is not enabled

      med_gettlv:enp1s0f0: failed

      ieee8023_gettlv:enp1s0f0: failed

      send_msg: sendto = 44

      send_msg: sendto = 44