3 Replies Latest reply on Oct 26, 2016 4:58 PM by BenoitP

    Device cannot be added to IoT dashboard ("Device already exists")

    BenoitP

      Hi,

       

        This issue has been raised before, but I could not find a clear answer.

      Basically, when I try to add my device to the Dashboard, I get the error:

      Activation Rejected:  {"code":1409,"message":"          Device already exists"}  --> error

       

        I tried all the suggested solutions in the other posts (rebooted, cleared the registration data, re-activated, etc), but I always get the same result ("Device already exists"). I'm not doing anything special and I start from scratch, so why is this not working?

      I'm using the latest image. This is the only device I have, so my Dashboard currently has 0 devices registered.

       

      More specifically, here is what I did:

      1. Dashboard>Devices>Trash icon (Delete all of them)

      2. Reboot Edison: reboot

      3. In this order:

      systemctl status iotkit-agent

      systemctl stop iotkit-agent

      iotkit-admin initialize

       

      Dashboard>MyAccount>Details>Refresh Activation Code

      iotkit-admin activate «activation_code»

       

      And that's where I get the error code.

      I'm using my smartphone as a local hotspot for the Edison WIFI, and I use a separate network for the computer which accesses my Dashboard.

       

      Thanks,

      Benoit