3 Replies Latest reply on Feb 9, 2010 8:54 AM by Jeltz

    GA-H55M-UD2H AHCI BIOS hang please help?

    Jeltz

      Not sure if this is right place to post this, but it has an Intel copyright on the problem so here goes:

       

      Installed windows 7 x64 accidentally in IDE mode just fine. When I later set the BIOS to AHCI mode, the BIOS hangs at:

       

      Serial ATA AHCI BIOS, Version iSrc 1.20E
      Copyright (c) 2003-2008 Intel Corporation 23
      ** This version supports only Hard Disk and CDROM drives **
      Please wait. This will take few seconds.

       

      Controller Bus#00, Device1#F, Function#02: 06 Ports, 02 Devices

       

      Reset the CMOS and back to IDE mode just fine but I do not really want to have to reinstall the O.S to get AHCI working. Other brand motherboards and windows 7 cope with the IDE/AHCI change just fine.

       

      The only way I have found to get past this hang is to use a blank drive that has never had an IDE OS installed on it. (I checked this by reformatting an old SATA drive, and deleting the partition, AHCI BIOS then posts just fine if this is the ONLY drive in the system)

       

      Can I get past this problem without having to reinstall the O.S.?

       

      Thanks in advance.

        • 1. Re: GA-H55M-UD2H AHCI BIOS hang please help?
          Cpt.Dogfruit

          No, you will need to reinstall the OS with it  set as AHCI.

          1 of 1 people found this helpful
          • 2. Re: GA-H55M-UD2H AHCI BIOS hang please help?
            Jeltz

            Can the person at Intel who wrote this SATA BIOS at least tell me what code 23 means? I guess it could be spinup/ready time but it is several seconds until the SATA BIOS posts so unlikely.

             

            OK one more thing in common is all my O.S.'s are now installed on Hitachi drives (Deskstar 7k1000.C). I created a system image and restored it to a Samsung drive and the system booted under AHCI mode just fine. So more likely it is the drive make rather than the O.S. I have also heard of same issue with W.D drives. In all likelihood if I restore image to Hitachi it still won't boot but for completeness sake may try it soon....

             

            And yet.....these are stock standard SATA II drives so what gives with the error 23. I have tried various drive settings with Hitachi HDD utility (power management, SATA interface etc, jumper on/off) to no avail. While at one level my problem has been solved, I would like to get to the bottom of this as quite a few people are having this problem who might not have the luxury of having another manufacturers drive.

            • 3. Re: GA-H55M-UD2H AHCI BIOS hang please help?
              Jeltz

              Here is the solution to the problem for my Hitachi drive. (win 7 x64) (use at own risk)
              1) take a system backup (including system image) of your boot O.S. with windows backup
              2) create a system repair disk (DVD) with windows backup
              3) delete the partitions on your boot drive (not sure if this is necessary)
              4) boot to the repair dvd, follow instructions to restore latest system image
              5) reboot, change BIOS settings to AHCI, reboot and all should be just fine.

               

              For some reason the 1.20E AHCI BIOS just does not like to go past a disk that has a win 7 x64 IDE operating system on it, and restoring the image to the same drive seems to fix the problem.


              Jeltz