1 Reply Latest reply on Nov 4, 2016 2:10 AM by ctan94x_intel

    cannot install package on IoT gateway: cannot open Packages database in /var/lib/rpm error rpmdb: BDB2506

    PeterNYC

      While updating the packages on Intel DE3815TYKHE IoT gateway, the updating had stopped permanently and I rebooted after 10 minutes. When the system came back, there was no list of packages and I was not able to install the iot-developer-hub package. The following error messages were shown:

       

      rpmdb: BDB2506 file /var/lib/rpm/Packages has LSN 19/3473547, past end of log at 19/3447046

      rpmdb: BDB2507 Commonly caused by moving a database from one database environment

      rpmdb: BDB2508 to another without clearing the database LSNs, or by removing all of

      rpmdb: BDB2509 the log files from a database environment error:

      cannot open Packages(0) index: Invalid argument(22) DB: Berkeley DB 6.0.30: (January 23, 2014)

      error: cannot open Packages database in /var/lib/rpm package iot-developer-hub is not installed

       

      Please let me know how to fix the package manager database. I am an IoT developer evaluating the Intel IoT gateway with Wind River Linux and I am not very interested in learning the intricacies of Berkeley DB or Linux internals. Rather, I like to spend my time on the sensor code on the Arduino 101, the gateway and in the cloud.

       

      I did already Restore to Factory OS once after a package got corrupted during a manual one-by-one update (there were about 1400 updates listed!)