0 Replies Latest reply on Feb 7, 2010 12:52 AM by Thefinaleofseem

    DX58SO BIOS update simply will not work

    Thefinaleofseem

      I've been trying to update the BIOS on this darned thing and it simply won't work no matter what I do. I got this board around the middle of last year. When I got it, the very first thing I did was update the BIOS to the July update. No problems, all updated fine. I recently checked and saw that there have been a couple of updates since then.

       

      I downloaded the OS BIOS update and ran it from Windows 7. All went fine, it shut down...and came back to a black screen. Nothing at all no matter how long I left it. Rebooting did nothing, but pulling the plug for 10-20 seconds got it booting again. Windows told me upon login that the update was successful, but it definitely wasn't. Same version.

       

      So I tried the CD flasher. Burned the ISO, reboot, see it fail, set SATA ports to IDE instead of AHCI, and it loads. Tell it to go ahead and flash, it sits for a sec, shuts down, powers up...black screen again. Same. Friggin'. Issue.

       

      Now, something I should note about this board: Whenever it's left unplugged for 20 seconds or so, it resets the CPU multiplier back to the default. As far as I can tell, this is the ONLY setting that gets reset. The clock and everything else are fine. The event log showed a CMOS battery failure a while back. I replaced the CMOS battery but saw no difference at all. When I replaced it, I got the full BIOS reset and had to reset the clock.

       

      I've tried resetting the BIOS to default and then flashing, but that makes no difference. What the heck is going on here? Do I just have a bum board or something?