4 Replies Latest reply on Oct 18, 2016 8:20 AM by Intel Corporation

    Razer Core cannot be Connected - NUC6i7KYK Windows 10

    caecar

      This problem is similar to the post "No Thunderbolt device in device manager - NUC6i7KYK Windows 10" https://communities.intel.com/thread/104165 . I Create a new thread because that one is two months ago and they are mostly discussing thunderbolt networking.

       

      I bought a Razer Core with Leadtek GTX 1070 graphics card. At the the very first time I plugged the Core, which is with an empty PCI slot, to the NUC, it worked so well that I successfully installed the Core driver. I can confirm since the Core's LED lit after the driver setup.

       

      After a reboot to get the 1070 installed, it cannot be recognized any more. I tried to reinstall the thunderbolt driver and it does not help. While I try to flash the firmware of the thunderbolt, I found that I cannot get the controller. Just like some image in that post I mentioned, there's "Unknown" at "controller driver version" section.

       

      It looks like that the thunderbolt controller driver doesn't work, while I don't know exactly what happened since there's no logs neither LEDs.

       

      I update the windows to the latest pack and the BIOS(42).

       

      The two screen capture are in Chinese. One's the thunderbolt software and the other is from the device manager, showing hidden devices. Whatever, the language doesn't impact the real message...

      details.PNG

      Device manager.PNG