5 Replies Latest reply on Oct 21, 2016 2:52 PM by Intel Corporation

    Problem with onboard wifi

    zubinp

      Hi,

       

      I have installed Ubuntu 16.04 on my Aero board and everything works fine except that the wifi exhibits a weird behavior. When I power up the board, the wifi works fine and I can connect to the internet. But when I restart the the board, the wifi networks vanish and the network icon shows "No network devices available". But if I power cycle the board, I get back the wifi connection. What is the difference between powercycling the board vs rebooting it ?

        • 1. Re: Problem with onboard wifi
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi zubinp,

          Thanks for your interest in the Intel Aero Platform.

          I'm sorry to hear that it doesn't connect to Wi-Fi when you do a restart. I will investigate more about this issue and I will get back to you.

          I hope you have a great day.

          Regards,  
          -Jose

          • 2. Re: Problem with onboard wifi
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hi zubinp,

            Thank you for your patience.
            I'm afraid we have confirmed that Ubuntu is not supported with the Intel Aero Platform and this may be the reason why you are experiencing problems. 
            So we would like to know, were you experiencing this same issue with the default image?

            Regards,  
            -Jose

            • 3. Re: Problem with onboard wifi
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi MASiddiqui,

              Were you able to check if you had the same issues with the default image? I will be waiting for your reply.

              Have a nice day.

              Regards,  
              -Jose

              • 4. Re: Problem with onboard wifi
                zubinp

                H Jose,

                 

                Sorry for the late reply. With the default image I was getting the same error as mentioned in this post WiFi wlan0 interface missing on power up .

                But I did not experiment further with the default image and replaced it with Ubuntu 16.04.

                 

                I wanted to ask if support for Ubuntu 16.04 is on your product roadmap in near future?

                 

                Regards,

                Zubin

                • 5. Re: Problem with onboard wifi
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi zubinp,

                  I would recommend to stay tuned for the firmware update of the Intel Aero default image. Regarding the Ubuntu 16.04 support I will notify the team in charge, so they can consider this for the future supports. I know this not the answer you were waiting, but we still appreciate if you could post any updates regarding your use of Ubuntu 16.04, so it will benefit other users. If there is any more technical problems please don't hesitate to contact us.

                  Have a nice day.

                  Regards,  
                  -Jose