3 Replies Latest reply on Feb 14, 2010 6:26 PM by ZXTT95

    Intel SSD Toolbox reports me "SCSI not supported" with X25-V

    sboirot

      I've just installed a Windows XP Pro on an X25-V SATA SSD, plugged in an Asus M4A785TD-V EVO mobo, with AHCI activated in the BIOS. All works fine, but, when I launch Intel SSD Toolbox, it detects the SSD X22-V but indicates "SCSI not supported", so I can't do anything with this drive (no action button is active)... When I look a the system properties under Windows XP, it reports the SSD to be an "SCSI Disk drive" plugged to AMD AHCI compatible RAID controller"...What is wrong?! How can I do the optimisations (trim,...)?!

        • 1. Re: Intel SSD Toolbox reports me "SCSI not supported" with X25-V
          sboirot

          Beginning of a solution... If I get back to IDE compatibility in the BIOS, INTEL Toolbox is OK to operate on the SSD... But it's not very cool: the performance I'll gain trimming the disk, will be lost if I'm on IDE mode...!

           

          Another problem...: anyway, I've got a second problem: in fact, INTEL Toolbox refuses to  trim, because of the presence of Shadow Volume Data for this disk... So same problem that was reported here several times...

          • 2. Re: Intel SSD Toolbox reports me "SCSI not supported" with X25-V
            sboirot

            I've to answer myself to get some response here :-((

             

            My initial problem persists... When my SSD is plugged in a SATA port that is declared as AHCI in the bios of my motherboard (ASUS M4A785 TD-V), the Intel Toolbox 1.2 reports me "SCSI not supported"...! When it's plugged to a SATA port declared as IDE, no problem...

             

            I've read many time in this forum that AHCI is well supported with Toolbox 1.2... So, I don't understand why toolbox reports me a problem, and I don't understand why "SCSI" is involved here... What is the relation between SCSI and AHCI?!

            • 3. Re: Intel SSD Toolbox reports me "SCSI not supported" with X25-V
              ZXTT95

              This probably comes down to how the driver for the SATA controller was written.  If it was written as a Storport driver, then the controller would appear in the "Storage controllers" section of device manager.  If it was written as an ATA driver then it would appear in the "IDE ATA/ATAPI controllers" section.  On my motherboard, the Intel SATA controller appears in the IDE section, but the JMicron appears in the Storage section.

               

              I don't know for sure, but probably there is no way (or no general way) for software to tell that a controller with a Storport driver is really a SATA controller and there is no way to send ATA commands to it.  Another way to put this is that by using Storport, the controller is turned into a generic storage controller from the point of view of the OS and other software.