1 Reply Latest reply on Oct 13, 2016 2:41 PM by Intel Corporation

    miss debug.node in XDK

    JamesLeo

      Hi,

      When I try to debug my code on XDK, there is a error message at Debug Window:

      Error: Cannot find module '/opt/xdk-daemon/current/node-inspector-server/node_modules/v8-debug/build/debug/v0.7.7/node-v46-linux-ia32/debug.node'

       

      Where can I find/download the file ?  how to patch?

       

      Thanks

       

      James

        • 1. Re: miss debug.node in XDK
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi JamesLeo,

          I’d love to help you with that, I tried to debug the example: Onboard_blink, at the beginning I had the same error when I tried to debug it. So, I removed xdk-daemon and I installed again, so try to follow the next steps:

          1. Close Intel® XDK.
          2. In the Edison serial terminal (I normally use PuTTY), update AlexT repository and MRAA (Install MRAA 1.4.0). 
          3. If you install xdk-daemon it should say that it is already installed, so tried to run the following command: opkg remove xdk-daemon
          4. Install it again with the command: opkg install xdk-daemon
          5. Open XDK and try to debug again.

          It worked to me, so I recommend you to do the same.

          Let me know if it works for you.

          Regards, 
          -Leonardo