6 Replies Latest reply on Oct 14, 2016 11:20 AM by N.Scott.Pearson

    NUC5i7RYH CIR problems

    fungyei

      I've got an RC-6 compatible remote (HP: TSGH-IR04) and enabled all CIR functions in Bios.

       

      The Remote successfully switch on my computer, yet it does nothing in Windows 7 (64-bit).

       

      I had the Infrared: Nuvoton* Consumer Infrared (CIR) Driver for Windows 7* for Intel® NUC (Version: 2.7.1005) installed, upon failure to response to the remote, I tried uninstall it and reinstall it, but then the installer prompt me an error saying the the CIR device is not found.

       

      So my questions are:

       

      1. How can I remove / reinstall the Nuvoton driver? (I've uninstall, restart, but in Device Manager, it shows an unknown device)

      2. How can I make my remote working in Win 7 (e.g. in Windows Media Centre)?

       

      Thanks a lot.

       

      P.S. The unknown device is: Mobile 5th Generation Intel(R) Core(TM) Premium SKU LPC Controller - 9CC3 <-- this is the device that I cannot remove (it stays there upon restart).
      Error code is 28.

        • 1. Re: NUC5i7RYH CIR problems
          N.Scott.Pearson

          How do you have CIR configured in the BIOS? In Visual BIOS, click on Advanced, then Devices and then Onboard Devices.

          I have found that, with my two remote types (RHRC-11001 and RC2604301/01B), setting it for Generic Remote Controller works best.

           

          After removing the driver, you need to reboot before attempting to reinstall the driver.

           

          The LPC controller is part of the chipset (PCH component). You may have to reinstall the Chipset package.

           

          Hope this helps,

          ...S

          • 2. Re: NUC5i7RYH CIR problems
            fungyei

            I performed a system restore and managed to have the Nuvoton CIR driver being shown working normally.  I will try changing the BIOS CIR setting as you suggested to see if I can get the NUC responsive to my RC-6 remote.

            • 3. Re: NUC5i7RYH CIR problems
              Intel Corporation
              This message was posted by Intel Corporation on behalf of

              Hello fungyei,
               
               
              I’m glad that now you have the CIR shown and working normally, please let us know how it goes after you try N. Scott Pearson suggestion.
               
               
              Best regards,
               
               
              Ivan   
               

              • 4. Re: NUC5i7RYH CIR problems
                fungyei

                Upon several attempt, it works now.  But I don't have idea on what goes right or wrong.  I suspect the case may be:

                 

                In previous installation of the Nuvoton driver, I just double click on the downloaded file (and the extractor and installer starts, and the "CIR device not found")
                While in my last attempt, I extract it first and then click on the installer, and at my surprise, it works and my NUC response to my remote successfully!

                 

                and Re: N.Scott.Pearson's suggestion, I finally set it as "RC-6 remote control" instead of "Generic remote control" in BIOS.

                 

                Thanks everyone.

                • 5. Re: NUC5i7RYH CIR problems
                  Intel Corporation
                  This message was posted by Intel Corporation on behalf of

                  Thank you for taking your time to share this information with us and I hope you can have a better experience with the Intel® unit from now on.
                   
                   
                  Regards,
                   
                   
                  Ivan
                   

                  • 6. Re: NUC5i7RYH CIR problems
                    N.Scott.Pearson

                    Well, I cannot say it with any certainty, but I had an "aha!" when you described your installation processes. The driver packages from Intel that come as ZIP files should always be extracted to a directory structure before installation. I say this because the support for extraction-on-the-fly can be spotty and (IMHO) not trustable.

                     

                    ...S