4 Replies Latest reply on Oct 23, 2016 8:07 PM by Intel Corporation

    i219-v limit to 10mbps

    rainbringer

      Hello,

      I've installed a new PC with Windows 10 Pro x64 on M/B Gigabyte H170M-D3H. The ethernet adapter is intel ethernet connection i219-v. Current drivers are 12.15.23.1. The problem appeared with previous version of drivers also.

      The problem is that my internet is now limited to 10mbps, when my true speed suppose to be 100mbps. My previous PC was connected to the same LAN socket with the same cable and with speed 100mbps.

      • I've tried to connect the cable to laptop, and it also has 100mbps, so the problem is nor the router, neither the cable.
      • I've tried to manually set Duplex&Speed to 100mbps Full and Half - with both options the negotiations fails and appears "cable disconnected'.
      • Auto-negotiation make the speed be 10mbps.
      • I've set in BIOS the speed to 100mbps Full - didn't help.
      • I've tried to disable/enable the device.

      All my attempts failed and I can't speed up to 100mbps.

       

      Please help!

      Thank you.