2 Replies Latest reply on Oct 21, 2016 3:23 PM by Intel Corporation

    Edison IIC Crash

    tapgar

      Hello,

       

      I am interfacing an MPU6000 with the intel edison.  I have set it up an interrupt so the mpu can tell the edison when data is available.  This is happening at 1 kHz.  At this rate it doesn't take long before I2C crashes.  I have looked around and it appears to be a common enough issue.  Basically the same as this Critial Issue: Edison I2C crash

      Everything I have read says the only fix is to roll back to 2.0.  So I reverted my FW to 2.0 but now I need a compatible IDE right?  The edison would be perfect for my application if I can get past this issue but I'm running out of time.

       

      Here's what I2C does after a couple read/writes

       

      And then it basically stays in this state until I power cycle.

       

      Thanks in advance,

      Taylor

        • 1. Re: Edison IIC Crash
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Taylor,

          Thank you very much for your interest in the Edison boards.
          I would like to know some more information about the issue, thanks in advance for your answers.

          1. Which Edison platform are you working on?
          2. Does it take a specific amount time before the I2C crashes? Have you noticed any pattern?
          3. Which IDE (and version) are you using right now?
          4. Have you tried with different IDE versions already?
          We’ll be waiting for your reply.

          Regards,
          -Pablo
          • 2. Re: Edison IIC Crash
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hi Taylor,

            I’m wondering if you’ve been able to work on this lately. I would really appreciate if you could answer my questions so we can keep helping you with this.

            Regards,
            -Pablo