4 Replies Latest reply on Oct 5, 2016 7:19 AM by Intel Corporation

    How to downgrade a particular (regular) USB 3.0 port to USB 2.0? NUC5i5RYH

    JoPeters

      Dear all,

       

      How can I "downgrade" a particular (regular) USB 3.0 port to USB 2.0? (E.g. via BIOS settings?) I am using my Intel NUC 5i5RYH as a HTPC. An external USB 2.0 TV card is connected to the NUC. Therefore, I plugged in an USB 2.0 hub into one of the regular USB 3.0 ports at the backside, and the only device that is plugged into this USB-hub is the external TV card (TT-connect CT-3650 CI, USB 2.0)). From time to time several erros occur. A lot of articles point out that all these external USB 3.0 TV cards have trouble collaborating with USB 3.0 (caused by their drivers). They should be plugged into USB 3.0. But: I don't want to connect the TV card to an internal (built-in) USB 2.0 port, which is available inside the NUC box. Instead, I'd like to downgrade one particular regular USB 3.0 port to USB 2.0. How to do this?

       

      Thanks in advance, and kind regards,

      JoPeters

        • 1. Re: How to downgrade a particular (regular) USB 3.0 port to USB 2.0? NUC5i5RYH
          N.Scott.Pearson

          Your query is kind of confusing (I think you said USB 3.0 where your meant USB 2.0 in at least one place) but I will attempt to answer it...

           

          1. Every USB 3.0 port has a full USB 2.0 port built into it and, if a USB 2.0 device is plugged into a USB 3.0 port, only the internal USB 2.0 port is used. That is, the USB 3.0 port automatically downgrades itself to support the USB 2.0 device.
          2. Plugging a USB 2.0 hub into the USB 3.0 port and then plugging the USB 2.0 device into this hub accomplished nothing (well, other than adding an additional point of contention and potential failure). I believe that you should just plug this TV Tuner directly into the NUC (though, if the TV Tuner's driver has issues with USB 3.0, this may still bite you).
          3. You can disable xHCI Mode in the BIOS (Select Advanced then Devices then USB (tab) and then set parameter xHCI Mode to Disabled), but I am not sure this will accomplish anything [Edit: and I believe it disables it for all USB 3.0 ports].
          4. The internal USB 2.0 ports in the NUC are actually behind an internal USB 3.0 router, so using them would, I belive, still leave you open to the driver issues.

           

          Hope this helps,

          ...S

          • 2. Re: How to downgrade a particular (regular) USB 3.0 port to USB 2.0? NUC5i5RYH
            JoPeters

            Hi N. Scott,

             

            Thanks for your hints. Yes, I meant "... these external USB 2.0 TV cards have trouble collaborating with USB 3.0 ...". I removed the USB 2.0 hub, and I plugged in the external USB 2.0 TV card directly into one of the regular USB-Ports at the backside of the NUC. I didn't disable the xHCI Mode in the BIOS, because this would affect all USB-Ports (as far as I found out), and I have two USB 3.0 devices. I re-installed the driver of the TV tuner, and - again - one error occured within the events:

             

            <Translated from German> „Device not migrated“

             

            The device "USB\VID_0B48&PID_300D\LHKBGF" couldn't be migrated.

             

            ID of the last device instance: USB\VID_14F7&PID_0003\0008C9D923F9

            Classes-GUID: {4D36E96C-E325-11CE-BFC1-08002BE10318}

            Persistance Location Path:

            Migration Rank (Sequence): 0xF000FFFF0000F122

            Exists: false

            Status: 0xC0000719

             

            Any idea? Except this error message, the device seems to work properly.

             

            Thanks, and kind regards,

            JoPeters

            • 3. Re: How to downgrade a particular (regular) USB 3.0 port to USB 2.0? NUC5i5RYH
              N.Scott.Pearson

              I am sorry, this is a new one on me, I have no idea what to do about it. I might suggest that you contact the maker of this device for more information. You might also want to post this question in Microsoft's Windows forums.

              ...S

              • 4. Re: How to downgrade a particular (regular) USB 3.0 port to USB 2.0? NUC5i5RYH
                Intel Corporation
                This message was posted by Intel Corporation on behalf of

                The only way to use USB 3.0 as USB 2.0 will be just like Scott mentioned previously, disable xHCI Mode in the BIOS (Select Advanced then Devices then USB (tab) and then set parameter xHCI Mode to Disabled), but again, this will disable USB 3.0 features to all ports. 

                Allan.