6 Replies Latest reply on Oct 28, 2016 9:34 AM by rwaldron

    Joule Constantly Rebooting

    Zates

      Hi I was trying to connect to the Joule through the serial port, although, the board would never boot up fully, and hang at a various places in the startup sequence. Tried going into the bios and making sure it boots from the SD card following the tutorial, at IoT - Flashing the development platform with the latest version of Reference Linux* OS for IoT | Intel® Software  but now the module just power cycles every couple of seconds spitting out

      Board Name = GrosseTete DVT2

        MRC REVISION ID 1.52.24

      MMRC REVISION ID 1.05
      every reboot.

       

      I also tried flashing a new BIOS, following this guide IoT - Flashing the BIOS | Intel® Software  But it also fails.

        • 1. Re: Joule Constantly Rebooting
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Zates,

           

          I will try to help you with this. According to the description you provided, the issue seems to be related to the power input, there might be other reasons for it but I would like to rule out this possibility first.

           

          Could you please let us know how you are powering your board?
          Are you using a battery, the barrel jack or any other method? If so, what are the specifications of this power supply?

           

          I will be waiting for your reply.
          -Peter.

          • 2. Re: Joule Constantly Rebooting
            Zates

            I have a 12v 1.5A barrel jack cable plugged in. I also tried powering it from the USB 3.0 port, and tried powering it via both, the barrel jack and the USB3.0 at the same time. The Joule was originally giving me some more output on boot but would hang at various points in the boot sequence, never to get me to the terminal, the problem came about when I entered the bios and toggled an entry in the boot configuration, that said something along the lines of "... boot every 500ms". After I enabled it just keeps rebooting, with no way of getting back into the bios.

             

             

             

            Also when I try to flash the device and hold the DNX boot button and plug in power to the device + the USB3.0 port, It stops rebooting but the side lights never come up, only the power LED. Windows device manager does say that a DNX device is recognized but the flashing still fails to download.

            • 3. Re: Joule Constantly Rebooting
              Zates

              I got it it to flash a new version of the BIOS using the method described in  Intel DnX Driver Doesn't work  although now that its not constancy rebooting, it starts the boot up sequence and then hangs at seemingly random points, with an SD card plugged in or not, and can't reach a terminal through the serial port.

               

              EDIT:
              I fixed the hanging issue by powering the Joule with only the USB3.0 port after having it flashed to the latest bios.

              • 4. Re: Joule Constantly Rebooting
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                I'm glad to hear that! If you ever have any other issues, please don't hesitate to come back to the community, we'll try to help you in any way we can.

                -Peter.

                • 5. Re: Joule Constantly Rebooting
                  McCool

                  You could simply have had a bad power supply.   Have you tried it with a different 12V supply?

                  • 6. Re: Joule Constantly Rebooting
                    rwaldron

                    From the "Material Requirements" page:

                     

                     

                    > 12V, 3A power adapter (power adapter must be Listed LPS or Class 2 output rated, 12Vdc, 3A minimum) with barrel jack for powering the expansion board. The barrel dimensions are 5.5mm outer diameter, and 2.1mm inner diameter. The barrel length is ~9-10mm. The plug is positive center.

                     

                     

                    Please don't read this as "rtfm", it is not. I had the same issue with a 12V 1.5A adapter that I had in my shop—I then purchased a 12V 3A adapter and the rebooting stopped. Here's the exact item I purchased: https://www.amazon.com/gp/product/B01DIUG7J6/