3 Replies Latest reply on Oct 3, 2016 2:42 PM by Intel Corporation

    Static screen after BIOS with the latest bios on Skull Canyon


      This happened after i flashed the bios to the latest one (041). The bios become unresponsive to and i was unable to make selection to enter setup (F2). I had to remedy by restarting several times, but the problem occur again on the next restart. Also another issue i'm having is, after the BIOS boots, instead of booting into Windows, i get a flickering static screen as shown in the screenshot below. Hard resetting my NUC would usually fix the problem on the next boot, but everytime i'm booting my NUC up, there's rougly 30% chance that would happen again. It has been happening many times since i purchased this NUC 3 days. Should i return? or RMA?




      Flashing the bios back to (037) helps remedy the issue, but i still have a lingering feeling about my NUC being defective since it cannot handle the latest BIOS without a hitch.

      I have also tried flashing the bios from 037 to 041 back and forth and it still doesn't solve the issue.