3 Replies Latest reply on Oct 24, 2016 3:05 PM by Intel Corporation

    How to Configure a 6700T System for Three Screens

    sproggit

      Hello everyone... First time post (please be gentle!)...

       

      I am the proud owner of a 6700T based system that uses an Asus Z170i Pro Gaming motherboard, coupled with 16Gb RAM and a 1Tb Samsung 850 Pro SSD. This machine is configured to dual-boot, with Windows 7/64 Pro and Mint Linux 17.3 (Rosa) 64-Bit... Everything works brilliantly except the graphics configuration. I have three Dell 2415, 24", 1920x1200 Monitors. I see some really weirdly different results when attempting to get this machine to drive these three monitors. Specifically:-

       

      Option 1, DisplayPort Daisy-Chain

      If I run a cable from the DisplayPort adapter on the case to a daisy-chain of these three screens [set 100% in alignment with the recommendations from Dell], then booting into Windows 7 gives me 3 screens, working perfectly, with a triple display and crisp, flicker free graphics. If I then reboot the system and launch into Mint with this exact same cabling setup, I see nothing on any of the three screens...

       

      Option 2, Split Duties

      If I run an HDMI cable from the motherboard's integrated HDMI socket to one monitor, then a DisplayPort cable to a second monitor [leaving the 3rd screen for a moment], then I can boot into Linux Mint and everything works perfectly. If I then reboot the system into Windows, the HDMI-connected monitor activates and works reliably, but the DisplayPort screen might only snap on for 5 seconds before snapping off. I get a window of about 15 minutes with the DP-connected display showing me Windows for a few seconds/minutes and then going dark again, before recycling. Eventually, after about 15 minutes, it goes dark and does not return.

       

      Option 3, Combination

      If I take the second configuration from above, then reconfigure the DP screen to be part of a DaisyChain, then connect in the third screen, I get nothing at all on any of the monitors...

       

       

      My ideal state would be to get Mint working as reliably with the daisy-chained DisplayPort setup as for Windows 7 (i.e. the first Option in cabling, above), but at the moment it appears to be a non-starter... If it is of any help, there is a breakdown of the Linux configuration of this system below, for your reference. Any suggests, recommendations, tests, etc, that could help me achieve a working 3-screen dual boot would be gratefully received. Thanks in advance... Not sure if this is relevant, but I spend 90% of my time with this System working with Linux, so most of my time I'm using 2 cables and 2 screens, with my 3rd screen dark ...

       

      inxi -c5 -Fxxz

      System: Host: SkyLake Kernel: 3.19.0-32-generic x86_64 (64 bit gcc: 4.8.2)

        Desktop: Cinnamon 2.8.8 (Gtk 3.10.8~8+qiana) dm: mdm

        Distro: Linux Mint 17.3 Rosa

      Machine: Mobo: ASUSTeK model: Z170I PRO GAMING v: Rev X.0x

        Bios: American Megatrends v: 0701 date: 11/16/2015

      CPU: Quad core Intel Core i7-6700T (-HT-MCP-) cache: 8192 KB

        flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464

        clock speeds: min/max: 800/2801 MHz 1: 800 MHz 2: 800 MHz

        3: 800 MHz 4: 800 MHz 5: 1900 MHz 6: 1100 MHz 7: 900 MHz

        8: 1200 MHz

      Graphics: Card: Intel Sky Lake Integrated Graphics

        bus-ID: 00:02.0 chip-ID: 8086:1912

        Display Server: X.Org 1.17.1 drivers: intel (unloaded: fbdev,vesa)

        Resolution: 1920x1200@60.0hz, 1920x1200@60.0hz

        GLX Renderer: Mesa DRI Intel Skylake DT GT2

        GLX Version: 3.0 Mesa 10.5.9 Direct Rendering: Yes

      Audio: Card Intel Sunrise Point-H HD Audio

        driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a170

        Sound: Advanced Linux Sound Architecture v: k3.19.0-32-generic

      Network: Card-1: Intel Ethernet Connection (2) I219-V

        driver: e1000e v: 2.3.2-k bus-ID: 00:1f.6 chip-ID: 8086:15b8

        IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>

        Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter

        bus-ID: 04:00.0 chip-ID: 168c:003e

        IF: N/A state: N/A mac: N/A

      Drives: HDD Total Size: 1000.2GB (3.5% used)

        ID-1: /dev/sda model: Samsung_SSD_850 size: 1000.2GB serial: xxx-=-=-=-=-=-xxx

      Partition: ID-1: / size: 16G used: 719M (5%) fs: ext4 dev: /dev/sda5

        ID-2: /tmp size: 7.4G used: 18M (1%) fs: ext4 dev: /dev/sda10

        ID-3: /usr size: 16G used: 5.8G (41%) fs: ext4 dev: /dev/sda7

        ID-4: /var size: 16G used: 1.1G (8%) fs: ext4 dev: /dev/sda9

        ID-5: /home size: 16G used: 4.9G (35%) fs: ext4 dev: /dev/sda8

        ID-6: swap-1 size: 16.53GB used: 0.00GB (0%) fs: swap dev: /dev/sda6

      RAID: System: supported: N/A

        No RAID devices: /proc/mdstat, md_mod kernel module present

        Unused Devices: none

      Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C

        Fan Speeds (in rpm): cpu: N/A

      Info: Processes: 236 Uptime: 2:14 Memory: 918.2/15932.9MB

        Init: Upstart v: 1.12.1 runlevel: 2 default: 2 Gcc sys: 4.8.4

        Client: Shell (bash 4.3.111 running in gnome-terminal) inxi: 2.2.28